[mythtv-users] Remaining Issues with 0.24 on Ubuntu 10.04 - new install

Bob Sully rcs at malibyte.net
Thu Dec 30 06:55:09 UTC 2010

OK...I've been having some problems with Myth since the upgrade to 0.24.

I've done a couple of dist-upgrades on the OS over the past year or so
(9.04 -> 9.10 -> 10.04) and Myth upgrades (0.22 through 0.24-fixes, using
JYA's binaries).

So, I figured there's probably some old crud lying around that's been
causing problems.

So, on an extra set of empty partitions, I set up a fresh install of 10.04
(I've decided to stick with the LTS releases), installed JYA's latest Myth
binaries and migrated the database over.


(1) Apparent python-binding problem which was preventing me from grabbing
metadata. I can now, as it seems to work OK.
(2) Severe problems with the nvidia-glx packages causing real problems
with the initrd - had been causing kernel panic with inability to boot at
all.  Now GONE.
(3) Problems playing a few MKV files under the internal player. Not
perfect, but 95% better.  (Most are fine...I have only about 10-11 of
these troublesome files in my whole collection)

(1) VDPAU playback problem with HD-PVR recordings:  only happened recently
(with the past couple of updates to 0.24-fixes) - juddery video and audio,
on HD-PVR content in the Recordings directories *ONLY*.  Other HD content
(HD-HR recordings and all "former" recordings (any source) - which I've
processed via ffmpeg and avidemux and now view via MythVideo - work fine).

I usually run VDPAU High-Quality, but it does the same thing with VDPAU

Someone else had commented on this same issue, and was told that he should
re-install the video drivers.  Well, I have installed the most recent
stable nvidia binaries (256) - still no go (and it had worked fine
previously with these same drivers).   So it doesn't appear to be the
video drivers.

There are *NO* errors in he log, except this one:

2010-12-29 18:05:21.118 VDPAU: Created VDPAU render device 1280x720
2010-12-29 18:05:21.159 Player(0): Forcing decode extra audio option on
(Video method requires it).
2010-12-29 18:05:21.159 FilterManager: Failed to load filter ' ', no such
filter exists
2010-12-29 18:05:21.256 Player(0): Video sync method can't support double
framerate (refresh rate too low for 2x deint)

It shouldn't be deinterlacing anyway...file is 720p resolution (h264,
HD-PVR recording).

I can watch all of the recordings without any problems if I use the CPU++
profile - but since it worked fine with VDPAU before, I'd like to get this

(2) News Feeds:  Selecting this under Info Center causes the frontend to
lock up.  I have to ssh in from another box (since my Myth GUI is
full-screen) and kill the mythfrontend process.  So, it's unusable. 
Anyone have a fix for this?

(3) There are also a couple of known bugs in Mythweb which are rather
annoying, but apparently have already been or are being addressed in
trunk, so will wait for the fixes to percolate down to 0.24-fixes.  ;-)

Thanks for all of the hard work...it IS appreciated.  Getting close to
having a completely-working system...!

Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list