[mythtv-users] playing bluray

John Welch jrw3319 at gmail.com
Wed Dec 29 04:54:03 UTC 2010

On Tue, Dec 28, 2010 at 11:18 PM, Robert McNamara
<robert.mcnamara at gmail.com> wrote:
> On Tue, Dec 28, 2010 at 8:12 PM, John Welch <jrw3319 at gmail.com> wrote:
>> On Tue, Dec 28, 2010 at 10:53 PM, Jean-Yves Avenard <jyavenard at gmail.com> wrote:
>>> On Wednesday, 29 December 2010, John Welch <jrw3319 at gmail.com> wrote:
>>>> Figured I would post here since I'm having essentially the same
>>>> problem as the OP.  Just got a new Plextor USB BD-drive, but so far my
>>>> attempts to use it with Linux/MythTV have failed.  When I run
>>>> 'mythavtest' with more verbose decryption logging I get a bunch of
>>>> stuff, which I'll be happy to post if requested.  However, I'm
>>>> guessing the key to my problem might be these two lines:
>>>> libaacs/aacs.c:618: Failed to initialize AACS! (0x238b130)
>>>> libaacs/aacs.c:630: AACS destroyed! (0x238b130)
>>>> I'm sure I've probably done something wrong with my setup work, but I
>>>> have no idea what.  Libaacs *seemed* to compile and install correctly,
>>>> and I installed the 64-bit binary of aacskeys into /usr/local/bin.
>>>> I've Googled both "error" messages that I've posted and got exactly zero hits.
>>> Libaacskeys is NOT libaacs
>>> You must install libaacs if you want your bd playback to work.
>>> _______________________________________________
>>> mythtv-users mailing list
>>> mythtv-users at mythtv.org
>>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>> Hmm, I *think* I at least have the right software installed.  I
>> downloaded libaacs from the VLC git repo, and ran through the
>> necessary steps (bootstrap, configure, make, make install (as root)).
>> I also downloaded aacskeys following the link in the wiki.  I copied
>> the pre-compiled 64-bit Linux binary that was included in this archive
>> into /usr/local/bin.  Not sure if I had to do this or not, but the
>> instructions I read somewhere seemed to indicate that it was
>> necessary.  Where did I mention "libaacskeys" that you are referring
>> to in your response?
> For the record, no, aacskeys, and libaacskeys are not required.  Only
> some information contained within its archive is required to properly
> configure the KEYDB.cfg file.  The point JYA was making is that you
> don't need to install any part of aacskeys to make this work.  You
> want libaacs, which according to your logs, you have.  Your issue is
> that your KEYDB.cfg is unconfigured.  Fix that and things will work,
> presuming you are attempting to play a disc for which you have a
> supported Processing Key. (meaning a disc with MKB v10 or less, which
> roughly equates to "released in early 2009 or earlier, and without
> BD+")
> Robert
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

OK, thanks for the help guys.  I get the point on aacskeys; need "some
info" in the archive, not the binary itself.  I think I'm getting
closer, but still no playback.  I've edited the KEYDB.cfg file, but
not sure I have the proper format yet.  I guess I'll keep plugging
away.  I'm using "older" blu-ray releases for testing, but can't say
for sure they match the criteria you've listed -- don't know how to
check either.

More information about the mythtv-users mailing list