[mythtv-users] Failed to change channel error

Harry Devine lifter89 at comcast.net
Tue Dec 28 20:16:09 UTC 2010

On 12/28/2010 03:06 PM, Jim Morton wrote:
> On 12/28/2010 2:54 PM, Harry Devine wrote:
>> On 12/24/2010 02:48 PM, Harry Devine wrote:
>>> On 12/24/2010 02:16 PM, John P Poet wrote:
>>>> On Fri, Dec 24, 2010 at 10:04 AM, Harry 
>>>> Devine<lifter89 at comcast.net>  wrote:
>>>>> I just re-did my capture cards after I upgraded to 0.24 and I 
>>>>> noticed that
>>>>> none of my HD-PVR recordings were happening.  So I just setup a test
>>>>> recording, and captured the following in my myth-backend log:
>>>>> I can "cat" my HD-PVR successfully, so I know it works OK.  And I use
>>>>> firewire to change channels which has always worked (unless something
>>>>> changed there that I'm not sure of yet).
>>>>> Any ideas on what could be happening?
>>>> Some people have had trouble with the 0.23 to 0.24 upgrade, where the
>>>> freqid column in the channel database looses it's value somehow.  This
>>>> can cause the symptoms you are seeing.
>>>> If you bring up mythweb, check to make sure that for each channel on
>>>> the HD-PVR, that the "freqid" value matches the "channum" value.  If
>>>> it doesn't, fix that, and it will probably fix your problem.
>>>> John
>>> I just verified that they match.  I tried using the 6200ch program 
>>> earlier to change channels via firewire and it failed, so I removed 
>>> the cable and put it back in, and it worked again.  However, I still 
>>> have the same problem trying to record (same errors I should say).
>>> Has something changed in the mythtv-setup on the 0.24 upgrade that 
>>> would cause the backend to fail in changing channels?  It seems like 
>>> this is where the issue is.
>>> I can put up more logs or info if anyone wants to see it.
>>> Thanks,
>>> Harry
>> Anyone?  Since the channel is on a HDPVR source, is Myth trying to 
>> change the channel on the HDPVR itself instead of via the Firewire?  
>> I tried putting the following into the Input Connections for the 
>> channel changer script, but it didn't work: "/usr/bin/6200ch 
>> %CHANID%".  I can run 6200ch manually and it works OK.
>> Thanks!
>> Harry
> I'm certainly no expert but if you can run the script manually and it 
> works then it sounds like a permissions issue.
> Does the script have rwxr-xr-x permissions?
> Try logging in as the myth user and running the script (without sudo.)
> I believe the entry should be just '/usr/bin/6200ch'.
> Beyond that I'm not gonna be much help.
It has 755 (rwxr-x-r-x) and is owned by root.root.  But I can run it 
manually as my normal user and it changes the channel fine.

Thanks for the suggestion though.

More information about the mythtv-users mailing list