[mythtv-users] Santa Brought Daddy a new T.V.

P.J. Trudell pjtrudell at yahoo.com
Tue Dec 28 01:46:46 UTC 2010

Well it was time for a new TV in the kids play room so I got a 42 in Panasonic.  My old front end/back end combo resides there only as a back end, so it was time to recommission the front end on it.  I knew that the video card there was bad or going bad because when it was strained with a DVD it ended up losing one of the colors and had a Blue tint until a hard reboot.

  I did my research and a good 1 gb Nvidia card came up to the front and I got the VGA ZOTAC|ZT-20203-10L GT220 1G R.  I figured the hard part would be getting the hdmi sound to work, but I am always up for a challenge.

My problem is the video.  I cant get it to work.  I am running ubuntu 10.10 and when there is not xorg.conf I get graphics, but the screen size is bigger than the monitor.  I lose about a inch on all sides so I can not see any of the top applications menu in X.  In myth I lose some of the menus also.  In this mode Nvidia drivers are not loaded, and I cant seem to figure out how to adjust the screen size.

a quick "nvidia-xconfig" gives me a good xorg.conf file and a roobot should give me control and the nvidi driver I installed (ubuntu and via the latest nvidia drivers).  No luck.  I end up with a text login prompt after gdm fails on a reboot.  Bellow is the xorg log showing the reason for the failure:

[    29.878] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[    29.878] (II) NVIDIA(0):     enabled.
[    30.078] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0. 
[    30.078] (EE) NVIDIA(0):     Please check your system's kernel log for additional error
[    30.078] (EE) NVIDIA(0):     messages and refer to Chapter 8: Common Problems in the
[    30.078] (EE) NVIDIA(0):     README for additional information.
[    30.078] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!

Here is the kern.log 

Dec 26 21:50:23 myth-server kernel: [   13.172377] nvidia: module license 'NVIDIA' taints kernel.
Dec 26 21:50:23 myth-server kernel: [   13.172382] Disabling lock debugging due to kernel taint
Dec 26 21:50:23 myth-server kernel: [   14.088530] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Dec 26 21:50:23 myth-server kernel: [   14.088538] nvidia 0000:01:00.0: setting latency timer to 64
Dec 26 21:50:23 myth-server kernel: [   14.088543] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
Dec 26 21:50:23 myth-server kernel: [   14.088668] NVRM: loading NVIDIA UNIX x86 Kernel Module  260.19.06  Mon Sep 13 06:35:06 PDT 2010

I googled "gt 220 and  Failed to initialize the NVIDIA graphics device" and found a guy with a similar problem, but it was never solved.

Well,  I figure I gave 2 options.  1.  Get a different new video card, or 2.  Try a fresh install.  Any suggestions.  I have tried, new power source, Ubuntu Nvidia driver, Nvidia's driver 260.19.29.

Thanks for the help
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20101227/edc9310e/attachment.htm>

More information about the mythtv-users mailing list