[mythtv-users] Sound issue is is baaaaack....0.24-fixes

Bob Sully rcs at malibyte.net
Tue Dec 21 08:31:06 UTC 2010

Jean-Yves Avenard wrote:
> On 21 December 2010 16:53, Bob Sully <rcs at malibyte.net> wrote:
>> Just wondering if the sound code has been tweaked again in the two
>> latest
>> 0.24-fixes versions.  I had this problem a while back...problem resolved
>> as of 20 November, right after Jean-Yves posted this up:
> if you're running my repo, it's tweaked a lot :)

I am.

> if using plain 0.24 not really.
> A fix went in but nothing that could affect your issue
> I remember your email, and did nothing to fix anything ; as the
> problem is with your setup and not myth code
>> Under "Music Settings", I have "Audio device" set to "default", and
>> "Upconvert stereo to 5.1 surround".  The receiver tells me it's getting
>> 5.1 input when the file begins to play (status bar moves, timer
>> increments), but there is *NO sound*.
> can't you provide a log with -v audio ?
> I think I know what problem you are having..
> Try the following:
> Go into advanced audio settings:
> check override audio passthrough, and in there enter:
> ALSA:iec958:CARD=Intel,DEV=0,AES0=6,AES1=0x82,AES2=0x00,AES3=0x01
> See how you go.
> This is what I changed lately that could affect your problem. Adding
> this broke it for some other.
> I guess in your case, it's reacting properly and it's the other person
> that was weird.
> JY

Tried this.  It worked...until I upgraded to the latest version you just
put up (fixes/0.24 [1d7eabf]).  Now it segfaults when switching to music,
with or without the above change.

2010-12-21 00:07:57.767 Pulse: PulseAudio suspend OK
[ac3 @ 0x310b220] No channel layout specified. The encoder will guess the
layout, but it might be incorrect.
2010-12-21 00:07:57.796 AudioOutput Error: AC-3 encoder initialization failed
2010-12-21 00:07:57.796 AO: Opening audio device 'iec958:CARD=Intel,DEV=0'
ch 6(2) sr 44100 sf signed 32 bit reenc 0
2010-12-21 00:07:57.796 ALSA, Error: Channels count 6 not available:
Invalid argument
2010-12-21 00:07:57.796 ALSA, Error: Unable to set ALSA parameters:
Invalid argument
2010-12-21 00:07:57.796 AO: Aborting reconfigure
[mp3 @ 0x7f4fd40ff470] max_analyze_duration reached
[mp3 @ 0x7f4fd40ff470] Estimating duration from bitrate, this may be

In addition, I've had problems with grabbing metadata on my BE/FE machine
since the switch to 0.24 (though it works on the remote FE machine
upstairs), Mythnews doesn't work on either box (crashes mythfrontend, have
to kill it from another machine or term), and for the past day or two I've
also had problems with juddery video and audio on playback of all HD-PVR
recordings on the BE/FE (worked fine before; recordings from the HDHR
still play fine).

I'm thinking that it might be time for a fresh install on the BE/FE box,
after backup of the database.  :-/

This is the same setup I've been running since 0.21 or 0.22.  Probably a
lot of old cruft lying around.

Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list