[mythtv-users] Need Help: HD-PVR IRBlaster

Martin Lynch martin.lynch.toronto at gmail.com
Mon Dec 20 20:02:04 UTC 2010

 >On Dec 20, 2010, at 11:43 AM, Martin Lynch wrote:

 > > *Resent in plain text; changed subject to avoid confusion with Mark 
Pennock's thread*
 > >
 > > On 10-12-18 10:10 PM, martin.lynch.toronto at gmail.com wrote:
 >> >> Following some good advice I received here, I've gone ahead and 
bought the Hauppauge HD-PVR. It works fine, except I cannot get the 
IRBlaster to work. It's been 2 weeks now of Googling and trying all 
manner of suggestions.
 >> >>
 >> >> Two questions:
 >> >>
 >> >> - can anyone who has the IRBlaster working with an HD-PVR 
possibly post lircd.conf and hardware.conf? Am running Ubuntu 10.04, if 
that's important.
 >> >>
 >> >> - can anyone who is successfully changing channels on a Bell 9241 
likewise post their channel changing script? I think (but am not 
certain) that this is equivalent to a Dish vip 612.
 >> >>
 >> >> I have compiled lirc_zilog and lirc_dev and downloaded the HD-PVR 
driver, etc etc etc.
 >> >>
 >> >> My IRBlaster plugs directly into the HD-PVR. I don't need the 
remote to work, just the channel changes.
 >> >>
 >> >> "irsend" doesn't work (variety of error messages, which I'm happy 
to post if needed).
 >> >>
 >> >> "irsend LIST "" """ returns nothing.
 >> >>
 >> >> I've been using firewire very successfully for the past 4 years, 
however my Bell boxes do not include a firewire port (I'm in Canada so 
they are not legally required to).
 >> >>
 >> >> Any and all help is very much appreciated, because I've been 
going in circles for days now on this.
 >> >>
 >> >> Thanks!
 > >
 > > OK, some additional info:
 > >
 > > /var/run/lirc/ contains lircd and lircd.pid
 > > /dev/ contains lirc0 and lircd, which is a link to 
/var/run/lirc/lircd (which I think I created manually - I've tried so 
many variations to get this working that I'm no longer certain...).
 > > $ sudo irsend -d /dev/lircd SEND_ONCE blaster select
 > > irsend: command failed: SEND_ONCE blaster select
 > > irsend: hardware does not support sending
 > >
 > > $ sudo irsend -d /dev/lirc0 SEND_ONCE blaster select
 > > irsend: could not connect to socket
 > > irsend: Connection refused
 > >
 > > /var/run/lirc$ ls -al
 > > total 4
 > > drwxr-xr-x  2 root root  80 2010-12-18 17:48 .
 > > drwxr-xr-x 25 root root 860 2010-12-19 07:42 ..
 > > srw-rw-rw-  1 root root   0 2010-12-18 17:48 lircd
 > > -rw-r--r--  1 root root   5 2010-12-18 17:48 lircd.pid
 > >
 > > $ uname -a
 > > Linux HTPC 2.6.31-11-rt #154-Ubuntu SMP PREEMPT RT Wed Jun 9 
13:40:34 UTC 2010 x86_64 GNU/Linux

 >Do you have a patched hdpvr driver that enables the IR part? That's
 >a requirement for lirc_zilog to be able to bind to the hardware. You
 >mention you "downloaded the HD-PVR driver", but I don't know exactly
 >what that means. What sort of output do you see in dmesg just after
 >driver load? (even better, after 'modprobe lirc_zilog debug=1'). You
 >appear to have *something* creating /dev/lirc0, but it doesn't seem
 >to be lirc_zilog.

 > > PS: when making changes to lircd.conf or hardware.conf (or changes 
to /dev/lirc) is it a requirement to restart lircd for the changes to 
take effect?
 >Yes, yes, and maybe (depends on the changes).

 >-- Jarod Wilson jarod at wilsonet.com

Many thanks for responding, Jarod!

Here's what dmesg contains:

[   14.401646] lirc_dev: IR Remote Control driver registered, major 251
[   14.404336] lirc_zilog: Zilog/Hauppauge IR driver initializing
[   14.408669] lirc_zilog: ivtv i2c driver #0: no devices found
[   14.408673] lirc_zilog: no device found
[   14.414267] lirc_zilog: chip found with RX and TX
[   14.414295] lirc_dev: lirc_register_driver: sample_rate: 0
[   14.414352] Zilog/Hauppauge i2c IR 3-0071: firmware: requesting 

martin at HTPC:~$ sudo modprobe lirc_zilog debug=1
[sudo] password for martin:
martin at HTPC:~$

I downloaded the HD-PVR driver from 
http://www.themainlan.com/mythtv/hdpvr-blaster-drivers.tar.gz following 
the instructions at http://www.mythtv.org/wiki/Hauppauge_HD-PVR.

Thanks for clarifying that I need to restart lircd after changes. Is it 
correct to start lircd via the command line with $sudo lircd? The 
command line arguments I posted previously are what are shown under 
System Monitor for lircd, however I simply typed "sudo lircd" - the rest 
of the arguments ("--output=/var/run/lirc/lircd --device=/dev/lirc")I 
take it came from lircd.conf? Actually, now that I look at it, the 
arguments point to /dev/lirc, which does't exist - only lirc0 and lircd 
(pointer to /var/run/lirc/lircd) exist. Tried stopping lircd and 
restarting with --device=/dev/lirc0 and doesn't make a difference. When 
restarting lircd, do I need to unload and reload lirc_zilog and/or lirc_dev?

I'm happy to start the whole process from scratch, if that's cleaner, if 
you can tell me how to get back to my original, pre-attempts state (ie, 
would I just stop lircd, modprobe -r lirc_zilog, remove lirc_zilog, 
restore the old lirc_dev, delete haup-ir-blaster.bin, delete /etc/lirc/  
and perhaps reboot or re-log-in?).

I see you devote an awful lot of time to the community regarding 
IRBlaster issues, Jarod - thanks, sincerely, for your help, and my 
apologies if it seems I'm being obtuse - trying to get this working 
reminds me of day 1 with Linux, 5 years ago - like learning a new 
language, and not one of those easy latin-based ones either!


Kind regards,


More information about the mythtv-users mailing list