[mythtv-users] Buffer failed too many times when switching shows

Adam Juraszek juriad at gmail.com
Sun Dec 19 11:43:05 UTC 2010

I've been trying to get mythtv working for more than two months, but
there are some problems which I still cannot solve.
I have a separated backend and the only applications running there are
mythconverg database, sasc-ng decoding, and mythbackend.
Backend is Debian Squeeze 2.6.32-5-amd64 with two TBS6981 cards.
Fronted is Asrock Nettop ION 330HT with archlinux and working vdpau.
Network is cat6 1Gb/s
I am primarily using it for watching LiveTV. I have upgraded a few
times and now I'm running a yesterday build of fixes/0.24

Using a Network-attached storage with raid 5, BE records there and FE
has mounted that directory:
It doesn't seem to be quick enough for LiveTV. If I use nfs option
atimeo smaller than 2 or even 0 than I can see messed image and log
says something about mp2 broken header and audio problems. Skipping
back in buffer (about 10 seconds) helped but switching shows and
channels didn't worked 100%.
Using atimeo higher than 2 causes nearly every show swich error
"Buffer failed too many times".
Streaming from backend didn't help.

Than I moved LiveTV recording directory to the local disk (only one)
into a dedicated partition (ext4). Mounting that folder via NFS on
frontend caused the same problems but there was a small improvement. I
have tried nearly every possible combination of nfs options.

Streaming from backend works fine except show switching.
Either at the end of show (if EIT is present) or at each half and
whole hour (if not). It usually works well. I can see a short stop
than a few tenths of second is missing and after that mythtv starts
playing next show; first second is not good but the rest is nice.
If the switching doesn't work, I can see a stop, the image freezes and
than for a timeout long while mythtv doesn't respond. After that
LiveTV gets back to main menu and the message "Buffer failed too many
times" appears.
In log is Waiting for video buffer for 100ms...
When I ssh to BE and ls -lt /storage/livetv I can't see the file
mythfrontend was waiting for.

Playing any recording is fine, so this issue is LiveTV related only.

I must have increased timeouts in RingBuffer.cpp to more than 10
seconds because of too slow decoding when switching to channel on the
same multiplex.

I can provide logs of FE and BE, which flags should I use?

Thanks for your time.

Adam Juraszek

More information about the mythtv-users mailing list