[mythtv-users] MythTv edit failing. Need to find another way

Paul Gardiner lists at glidos.net
Sun Dec 12 16:53:36 UTC 2010

On 09/12/2010 19:26, Paul Gardiner wrote:
> I often archive shows, first using MythTv's editing feature,
> a lossless transcode, and then Handbrake to recode as h264.
> On occasion the lossless transcode fails with "Deadlock
> detected. One buffer is full when the other is empty",
> but I can usually fix that by first remuxing with ffmpeg
> and regenerating the index. But I now have one recording
> that wont remux because of a duplicate time stamp. What
> other way can I edit the ends of a recording before
> compressing with Handbrake?
> I tried mencoder with an edit list, but that chopped
> off more than I asked it. I also tried using mencoder
> just to do the remux and let MythTv have another
> go at editing, but that put the sv sync out just a
> little.
> Any other suggestions?

I eventually found EasyMPEG that did the job - just
in case someone else runs into the same problem.

I guess the real solution is to fix ffmpeg so that it
doesn't stop when it finds a duplicate time stamp.
Maybe I'll have a go at that.


More information about the mythtv-users mailing list