[mythtv-users] 0.24, tmdb.py and MythVideo ... again!

Raymond Wagner raymond at wagnerrp.com
Sat Dec 11 14:15:57 UTC 2010

On 12/11/2010 07:39, Paul wrote:
>> Thank you for reporting back.  Can you share what you had done wrong 
>> for the archives/record?
> First I couldn't get the perl or python bindings to build / install at 
> all, until I figured out I didn't have all the prerequisites installed 
> for them to build.
> From the list of everything I have installed these are the ones I 
> think you need (Ubuntu package names):
> python-lxml
> python-mysqldb

These are the only two required by MythTV.  I have never heard of or 
have any idea what those 'egenix' packages are.

> libnet-upnp-perl

 From the configure list, the modules it is looking for are...


> I ran configure, make, make install and was then using checkinstall to 
> create a deb package. I then worked out none of the bindings were 
> being installed at all. I tried to install them manually and this made 
> tmdb.py work from the command line but not within MythTV.

There should be no difference between the two.

> So it seems to me that as long as you get the perl / python bindings 
> built and installed first and then build mythplugins and make sure 
> when you package you have the perl / python bindings within the 
> package things should be OK.

The Python checks should probably be adapted.  The NetVision and Video 
grabbers that use Python have been moved into the core installer, 
meaning the tools that need the modules are already installed by the 
time the check is performed.

More information about the mythtv-users mailing list