[mythtv-users] Troubleshooting a CrystalHD problem in 0.24

Tom Flair tom at graniteskies.net
Sat Dec 11 09:49:35 UTC 2010

On Sat, Dec 11, 2010 at 1:34 AM, Mark Kendall <mark.kendall at gmail.com>wrote:

> On 11 December 2010 12:18, Tom Flair <tom at graniteskies.net> wrote:
> > My frontend's response when playing back a video is this:
> >     2010-12-10 20:15:47.879 CrystalHD Err: Error at
> > privatedecoder_crystalhd.cpp:104 (#-1, Unknown)
> >     2010-12-10 20:15:47.880 CrystalHD Err: Failed to open CrystalHD
> device
> I suggest you go into the crystalhd/examples directory, compile the
> examples if necessary and then execute them. I'm guessing they won't
> work either.
> For what it's worth, I've noticed before that my BCM70015 seems to go
> MIA occasionally and I have to reboot to get it back.
> regards
> Mark
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

After a little digging, I found the required test_video.264 at
http://code.google.com/p/crystalhd-for-osx/downloads/list and was able to
confirm that I am getting some output from the card.

But only when I run the test program as root.  I compiled hellobcm as my
normal user.  I'm curious if this is why I was getting the
privatedecoder_crystalhd.cpp error.   So far, searching has resulted in a
lot of traffic related to the AppleTV installation, but not a whole lot for
linux and this problem.

Thanks for the tip, Mark.  I'll keep digging.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20101211/04b5a964/attachment.htm>

More information about the mythtv-users mailing list