[mythtv-users] 0.24: IPTV LiveTV failing to start

Per Lundberg perlun at gmail.com
Fri Dec 10 21:29:36 UTC 2010

On Fri, Dec 10, 2010 at 10:48 PM, Robert Johnston <anaerin at gmail.com> wrote:

Hi Robert,

Thanks for your prompt reply.

> Technically speaking, udp://ip.add.re.ss:port is correct. the @ syntax is
> for when there is authentication required, like so:
> udp://username:password@ip.add.re.ss:port/. If you put in the former style
> in VLC, it too will work.

This is actually a bit interesting... you may be "technically
correct", but the fact is that as soon as I remove the @ sign, the MRL
doesn't work in VLC. As soon as I put it in, it works. I guess I
should be asking the "why" for this on a VLC mailing list instead...
but still, it's a bit interesting.

If I remember correctly, MythTV must have the MRL *without* the @ sign
for the channel to properly be tuned.

I was thinking before that the @ sign would be indicating that the
stream is a multicast stream - causing the proper IGMP
subscribe/unsubscribe messages to be published. Is this incorrect? How
does MythTV know that the stream is multicast, by checking if the IP
address is within the "multicast range"? (I guess this would be quite
enough... :-)

> The errors you are getting because the file hasn't been created yet. This is
> probably due to there being a problem tuning it. If your interface has
> cycled recently (gone down and up again), it may be that your backend needs
> to be restarted to notice it's back up.

I did stop the backend, and started it again (with verbose debugging
turned on), so this did not help I'm afraid.

> I'm presuming that you are trying to tune using VLC on the same box (the
> backend system). If not, that might be something to test also.

This was actually not the case - the machines are on the same physical
LAN, but I was tuning with VLC on the frontend. Not too clever. I
tried from the backend instead and it worked (but playing video over
an ssh-tunneled X11 connection isn't optmial...).

I tried in MythTV again, and it didn't work. The strange thing is, the
exact same channel that didn't work in LiveTV tonight worked earlier
during the day for recording a program.

So, I'm out of clues by now. It might work if I would remove the input
card and re-add it, but... I don't like that idea, since it doesn't
really solve the problem "the right way".

(I managed to come around the problem with the "bad" channel being
cached in the settings table by running an SQL query like this:
"update settings set data = '5060' where value = 'DefaultChanid' and
hostname = 'htpc-linux'". It would be nice if the LiveTV mode in
MythTV would reset this automatically if it fails to tune the channel,
since you get into a quite tough situation otherwise... :-) Then
again, it wouldn't be so nice if MythTV forgets channel presets too
easily. My problem is that I have two tuners, DVB-S and IPTV and one
might work while the other doesn't.)
Best regards,
Per Lundberg

More information about the mythtv-users mailing list