[mythtv-users] 0.24 and video metadata, again

Mike Perkins mikep at randomtraveller.org.uk
Wed Dec 8 17:34:15 UTC 2010

On 08/12/10 06:11, Bob Sully wrote:
> Robert McNamara wrote:
>> On Tue, Dec 7, 2010 at 7:51 PM, Bob Sully<rcs at malibyte.net>  wrote:
>>> Movies:
>>> [mythtv at vader: ~]$ python /usr/share/mythtv/metadata/Movie/tmdb.py -M
>>> "Star Wars - Episode I - The Phantom Menace"
>>> 1893:Star Wars: Episode I - The Phantom Menace (1999)
>> This is .23-era output.  You have old bindings/scripts installed, not
>> .24 ones.  Once you have the actual .24 metadata scripts and bindings
>> installed, you should see XML output, and everything should work fine.
>> Robert
> Robert, thank you; I assumed that might be the case.  However, I've tried
> looking for old cruft, and re-installing several packages:
> mythtv-common
> mythtv-backend
> mythtv-frontend
> libmyth
> libmyth-python
> mythvideo
> mythnetvision
> No difference.  I still get the same output from tmdb.py and the "missing
> module" error with ttvdb.py (tvdbXslt), even though it does exist.
> I'm running the latest version of Python available for Ubuntu 10.04.
> I'm using Jean-Yves' binaries.  JYA, any clue as to what I'm missing here?
> While learning Python is definitely on my "to-do" list, my kids and my day
> job don't leave me the time for it now....!
Your displayed messages also clearly indicate that jamu (which supplies the info 
you require) must now be run on a back end machine, but all the commands you 
show were done on the front end machine.

This matters unless your frontend and backend are on the same machine. Try 
running your commands on the backend if you have a split system.


Mike Perkins

More information about the mythtv-users mailing list