[mythtv-users] 0.24 and video metadata, again

Bob Sully rcs at malibyte.net
Wed Dec 8 03:51:04 UTC 2010

Hi all -

Since upgrading to 0.24 (worked fine in 0.23), I've been having problems
with grabbing metadata for my videos - both movies ripped from my DVD
collection and recorded TV shows which I have edited and saved as .avi or
.mkv files.  The machine is a BE/FE running Ubuntu 10.04 and JYA's

After hitting the "W" key, it seems to go through the motions, but doesn't
return anything (or if it does, doesn't update the DB).

I haven't been using jamu (I have always done the metadata updates
manually), but I see the following in my /var/log/mythtv/jamu.log:

! Error: Jamu must be run on a MythTV backend. Local host (vader) is not a
MythTV backend.
With any -M option Jamu must be run on a MythTV backend
! Warning - Could not find setting 'BackendServerIP' on host 'vader'

Well, the IP address is where it should be in mythtv-setup:

I grepped "BackendServerIP" but didn't find anything, in the two files
that it came up with, I could change to fix this.

If I run it from the command line - the script for TV shows doesn't work,
but for movies, it at least is able to grab the data (but doesn't put it
into the DB):

[mythtv at vader: ~]$ python /usr/share/mythtv/metadata/Movie/tmdb.py -M
"Star Wars - Episode I - The Phantom Menace"
1893:Star Wars: Episode I - The Phantom Menace (1999)

python /usr/share/mythtv/metadata/Movie/tmdb.py -D 1893
Title:Star Wars: Episode I - The Phantom Menace
Director:George Lucas

[mythtv at vader: ~]$ python /usr/share/mythtv/metadata/Movie/tmdb.py -M
2164:Stargate (1994)
12914:Stargate: Continuum (2008)
13001:Stargate: The Ark of Truth (2008)
20498:Stargate SG-1: Children of the Gods - Final Cut (2009)
47279:Stargate Atlantis : Rising
44215:Stargate Movie Collection

[mythtv at vader: ~]$ python /usr/share/mythtv/metadata/Movie/tmdb.py -D 2164
Director:Roland Emmerich

TV show:
[mythtv at vader: ~]$ python /usr/share/mythtv/metadata/Television/ttvdb.py
-l en -M Nikita
! Error: Importing tvdbXslt error(No module named tvdbXslt)


[mythtv at vader: /usr/share/mythtv/metadata/Television]$ locate tvdbXslt

More information about the mythtv-users mailing list