[mythtv-users] [OT] LIRC multiple devices question/problem

Jarod Wilson jarod at wilsonet.com
Fri Dec 3 05:49:17 UTC 2010

On Dec 3, 2010, at 12:23 AM, Tom Lichti wrote:

> On Fri, Dec 3, 2010 at 12:06 AM, Jarod Wilson <jarod at wilsonet.com> wrote:
>> On Dec 2, 2010, at 11:56 PM, Tom Lichti wrote:
>>> This is not specifically a MythTV question, but I know there are many
>>> people here who can help (yes Jarod, I'm looking at you.. :) ) me out.
>> Who, me?
> Yup, you.. :)
>> lircd --driver=iguanair --device=/dev/iguanaIR/0, etc., etc., or similar,
>> if I'm thinking clearly.
>> The IguanaWorks guys were kind enough to send me hardware a while back,
>> but I'm not hugely familiar with it... The /dev/iguanaIR/0 thing should
>> change to /var/run/iguanaIR/0 or similar in the future (I provided them
>> a number of patches I used to sanitize an iguanaIR package I submitted
>> for Fedora package review), but there should also be a symlink to 0 that
>> matches the name of the device, if you've given it one, following their
>> first-time initialization steps.
> I figured it was something like that, I'll give it a shot tomorrow
> (okay, later today, once I've had some sleep).

I neglected to fully explain what that "device" actually is, which I
meant to do... Its really a socket, created by igdaemon -- which is why
it has no business under /dev/. But the iguanaworks guys cribbed that
from lirc, which historically had its lircd socket in /dev/ as well.
They're cool with further copying lirc and moving the socket similarly.

/me makes note to kick someone about that iguanaIR package review, which
has been stalled for weeks (months?) now...

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list