[mythtv-users] mythweb fails when searching for "other showing of a program"

Oz Dror odror7 at gmail.com
Wed Dec 1 04:19:53 UTC 2010

Thank you again

>  I'm on ubuntu 10.04 and 10.10, dpkg -l php5 should
>  show you're on 5.3.2-1ubuntu4.5 or later, right?

$ dpkg -l php5
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version        Description
ii  php5           5.3.3-1ubuntu9 server-side, HTML-embedded scripting languag

> If you're up for it, load the failing page, add the
> echo below and then reload the failing page. The
> SQL query will print on the top line. You can then
> run the query manually, to see if the error string
> in your initial post is related. Remove the echo!

> modules/tv/classes/Channel.php
> i// Query (Line 70)
> -------> echo($sql); <--------
> $sh = $db->query($sql);
> $channel_list = array();
> while ($chanid = $sh->fetch_col())

This is what I get

SELECT channel.chanid FROM channel WHERE channel.visible = 1 GROUP BY
channel.channum, channel.callsign ORDER BY (channel.channum + 0),
channel.channum, channel.chanid

I change my setup to be like yours. It makes no difference I still get
the error. I tend to agree with you that the old ID is probably not
the issue. It might be some
inconsistency in my setting record that mythweb is sensitive for or
possibly ( what I think a bug in mythweb). When I tried to file a bug
report I got very negative response.

Thank you,
I really appreciate your help.

More information about the mythtv-users mailing list