[mythtv-users] mythweb no longer usable with older OS

MarcT myrdhn at gmail.com
Sun Aug 29 15:49:34 UTC 2010

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Raymond Wagner
Sent: Sunday, August 29, 2010 10:30 AM
To: Discussion about MythTV
Subject: Re: [mythtv-users] mythweb no longer usable with older OS

  On 8/29/2010 10:22, Tom Dexter wrote:
> On Sun, Aug 29, 2010 at 2:18 AM, Michael T. Dean
> <mtdean at thirdcontact.com>  wrote:
>>   On 08/29/2010 01:39 AM, Mitch Capper wrote:
>>> Yep, php 5.3 is definitely still alpha on several os's.  I have been
>>> used the work around for that get_called_class call, and changed the
>>> requirement check and it has been working fine so far.   I am sure a
>>> get_called_class isn't great, but honestly a programming language
>>> (especially php which can have major changes to default behavior between
>>> versions) requiring the absolute latest isn't something I mind
>> PHP 5.3 is required because MythWeb is using PHP 5.3 features.  It's
>> available on all major distributions--including Fedora as far back as
>> 6.
> It's only a requirement past 0.23-fixes...that is for trunk and the
> upcoming 0.24, correct?

Correct.  0.23 and previous will continue to work on old versions of PHP.

For what its worth, FreeBSD installs PHP5.3 by default, and while 5.3 is 
masked on Gentoo, so is every MythTV 0.23 and 0.23.1 ebuild, and there 
are no trunk ebuilds.


There are no official trunk ebuilds. There are several unofficial layman
overlays that have trunk ebuilds in them.


More information about the mythtv-users mailing list