[mythtv-users] My mythtv gentoo overlay install failures since the 25803 FFMPEG sync.

MarcT myrdhn at gmail.com
Sat Aug 28 16:38:21 UTC 2010


Ok, fixed it. This was caused by the fix in 25816.

 

For those who care, I have added the below patch to my overlay.

 

# cat gentoo-myth-config-fix.diff

diff -u -r mythtv.orig/configure mythtv/configure

--- mythtv.orig/configure       2010-08-28 10:46:53.000000000 -0400

+++ mythtv/configure    2010-08-28 10:48:43.000000000 -0400

@@ -4749,9 +4749,9 @@

 cat >> external/FFmpeg/config.mak <<EOF

 LIBDIR=\$(INSTALL_ROOT)$libdir

 SHLIBDIR=\$(INSTALL_ROOT)$shlibdir

-INCDIR=\$(INSTALL_ROOT)$incdir

-BINDIR=\$(INSTALL_ROOT)$bindir

-DATADIR=\$(INSTALL_ROOT)$datadir

+INCDIR=$incdir

+BINDIR=$bindir

+DATADIR=$datadir

 MANDIR=\$(INSTALL_ROOT)$mandir

 endif # FFMPEG_CONFIG_MAK

 EOF

 

MarcT

 

From: MarcT [mailto:myrdhn at gmail.com] 
Sent: Saturday, August 28, 2010 3:47 AM
To: 'Discussion about MythTV'
Subject: RE: My mythtv gentoo overlay install failures since the 25803
FFMPEG sync.

 

For those that don't already know the location,
http://github.com/MarcT/mt-mythtv

 

MarcT

 

From: MarcT [mailto:myrdhn at gmail.com] 
Sent: Saturday, August 28, 2010 3:46 AM
To: 'Discussion about MythTV'
Subject: My mythtv gentoo overlay install failures since the 25803 FFMPEG
sync.

 

Need some help from someone more experienced in writing ebuilds.

 

Since the breakaway of FFMPEG into its own "external" folder, my overlay
fails on the install stage.

25803 to 25815 gives a sanbox error.

25816 and up gives the error : Aborting due to QA concerns: 54 files
installed in
/var/tmp/portage/media-tv/mythtv-9999/image///var/tmp/portage/media-tv/mytht
v-9999/image/

 

Anyone able to assist?

 

MarcT

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100828/310adef6/attachment.htm>


More information about the mythtv-users mailing list