[mythtv-users] MythVideo and CC

MacNean Tyrrell dardack at gmail.com
Mon Aug 23 16:41:43 UTC 2010

On Mon, Aug 23, 2010 at 12:28 PM, jedi <jedi at mishnet.org> wrote:

> On Sun, Aug 22, 2010 at 05:31:20PM -0400, Doug Lytle wrote:
> > MacNean Tyrrell wrote:
> > >So you choose the mkv format and not mp4?  Do you use h.264?
> >
> > Yes.  My front end is a Revo 1600
> ...something of note. Handbrake actually defaults to mkv for its high
> quality
> profile. So the idea of having h264 in mkv format rather than mp4 is not at
> all odd.

No i know.  I was using the mp4 format with h.264.  I've since started using
the mkv format with h.264 to get CC working in mythvideo.  Espeically for my
wife, who watches everythign with CC. Started when we lived near train
tracks, so would turn it on to know what's going on, then we had kids, so
she was paranoid about the tv waking the baby.  So CC has become kinda like
default when we watch TV. I don't even notice it anymore, unless i watch TV
somewhere else without it.  People think we're strange, how can you watch
and read.  Gah I ramble, sorry.

I don't understand your other post tho:

MPEG2 supports American NTSC closed caption encoding. American
DVDs quite often have NTSC captions as the "english subtitles" and
other video players treat them as such.

Does this mean that some of these movies, the CC handbrake is soft encoding
into the MKV container isn't supported?  I've tried everything based on the
chapter 22-23 in Star Wars A new Hope, it's the greedo scene.  So I have 2
VOSUB's soft encoded (i've tried just having 1 also).  The first defaulted
is the forced subtitles (ie when greedo is speaking rodain), the second is
the full CC.  Neither works.  Even if I just encode 1, it doesn't work.
Mythvideo recognizes that there is 2 CC tracks, as I can see them in the
Menu for CC (or 1 track if it's a test with just 1 track).  But it will not
display the track selected.  And yes it's been turned on and off multiple
times.  Again vlc and ubuntu's movie player (although movie player segfaults
part way in on the MKV file for some reason) both display the subtitles when

> [deletia]
>  _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


MacNean C. Tyrrell
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100823/eb6af505/attachment.htm>

More information about the mythtv-users mailing list