[mythtv-users] lirc confusion

Nick Morrott knowledgejunkie at gmail.com
Sat Aug 21 17:15:23 UTC 2010

On 21 August 2010 13:50, Paul Gardiner <lists at glidos.net> wrote:
> On 21/08/2010 11:50, Paul Gardiner wrote:
>> Hi,
>> I think I'm close.
>> 1) If I run irw, and press buttons, then the output shows the correct
>> buttons.
>> 2) I've placed the lircrc file from
>> http://www.mythtv.org/wiki/MCE_Remote in /home/linda/.mythtv, and the
>> buttons
>> in that file match those that irw displays.
>> 3) The logs from mythfrontend show
>> "LIRC: Successfully initialized '/var/run/lirc/lircd' using
>> '/home/linda/.mythtv/lircrc' config", and /var/run/lirc/lircd is the
>> right path.
>> Anyone any idea what I might have forgotten?
> I get output from "irw" but not from "ircat mythtv". At first ircat
> moaned about the absense of .lircrc, so I made a copy of .mythtv/lircrc
> with that name. That stopped ircat complaining, but it doesn't produce
> any output as I press buttons.

Note that you don't need to create multiple copies of lircrc - just
use a single ~/.lircrc file for each user and the LIRC tools and
MythTV will be happy. This help to cut down the potential for
confusion when tracking down LIRC issues, and makes for a simpler
setup overall.


Nick Morrott

MythTV Official wiki: http://mythtv.org/wiki/
MythTV users list archive: http://www.gossamer-threads.com/lists/mythtv/users

"An investment in knowledge always pays the best interest." - Benjamin Franklin

More information about the mythtv-users mailing list