[mythtv-users] Issues with Videos and Appearance

~Stack~ i.am.stack at gmail.com
Wed Aug 4 23:14:39 UTC 2010

Hash: SHA1

Hello all,

I will try to keep this brief, yet keep intact all the relevant
information (still a bit long; sorry). My old MythTV system was a
rag-tag group of spare parts that gave me no end of trouble (hardware
failures; expected from spare parts I got for free). Once I got a stable
Mythbuntu 8.04.1 working exactly the way I wanted, I froze the software
and left it alone for a year or so. Just dealing with hardware failures
was enough.

Recently, I have wanted all the cool features I keep reading about on
this list. So I bought almost all new components and yesterday they
arrived! I did a mythconverg_backup.pl of my old system, rsync'd all the
data (recordings, music, videos, pictures) to the new system with a
Linux live CD (new bigger drives, but kept the same mount points),
installed Mythbuntu 10.04 64bit, and did a mythconverg_restore.pl. I had
to adjust a few location points in the mythtv backend for storage
directories (which I knew because of this list) and I had seen the many
recommendations on this list of deleting capture cards information and
to re-add it. Once I did all the little tweaks I remembered seeing from
the list, I gave it a whirl.

It all worked! My backend was up and running. I was even able to enable
VDPAU to watch the HD versions of big buck bunny with the VDPAU settings
(don't have a lot of HD; part of the reason for the upgrade).

Everything went so smooth that I had a gut feeling that the universe was
saving up to really kick my @$$...

Then it was off to rebuild the remote frontends (as in, not in my office
with the backend). Mythbuntu didn't like the new 9400GT MSI video card
combo with my Sanyo TV. I had to use a regular monitor to do the
install, updates, and nvidia driver installations. At one point the
entire installation froze and I had to restart. After all that was
finally done, I could then boot and get MythTV up on my TV screen. So I
went to check out big buck bunny again (I know, HD on a SD tv...just
wanted to know VDPAU worked).

Problem #1.
Watch TV : works on remote frontend!
Watch Recordings : works on remote frontend!
Watch Videos : blank screen.

Well, I know that the Storage Directories are at least somewhat close as
it worked on the backend.

Utilities/Setup->Setup>Media Settings->Video Settings->General Settings
All of them are either /var/lib/myth/(entry) or
/home/user/.myth/(entry). There is no such thing as a /home/user/.myth
folder. Huh. So I set them to where they should be. Something like this:
Directory that holds videos: /media/drive1/Movies/
Directory that holds posters: /var/lib/myth/posters/
ect ect
Tried it again, still no go. So I turned to the internet. I found all
kinds of "solutions". "solutions" that really hosed up my Myth install.
Some time around 1 am last night I realized that the backend no longer
worked either and a lot of things were screwed up on it too. At which
point I was too angry to care so I went to bed...

After sleep and clearing my head, I turned to mythtv.org/docs/ for help.
Just to throw this out there, if you have contributed to that, you are
totally my hero right now.
After reading through a large portion of that document and following
some of the basic information I have been able to fix everything major
but two problems.

Problem #1
Still have it. Only now it is the same problem on both frontend and
backend system. Where it is at the very moment is:
Backend has locations set up for _everything_ in the Storage
Directories. Default points to the two drives that currently hold my
recordings. LiveTV has a pointer to a location. As does Posters,
Backups, ect, ect, ect. Videos points to /media/drive1/Movies/.

Both frontends point to those exact same locations as defined in the
backend as here:
Utilities/Setup->Setup>Media Settings->Video Settings->General Settings

When I used to go to Media Library->Watch Videos I would go into the
'top level' of /media/drive1/Movies/. Now I get:
Unknown->Media->Myth->Videos and now I am at the 'top level'.

When I hit enter on any movie, I get the title screen (filename and lots
of question marks about year, director, ect), and a button captioned
'play'. I hit 'Play' the screen goes black for a very brief moment then
returns to that title screen. Looking at the mythfrontend.log I see a
LOT of "Unable to find image file: No Cover" which I don't know where
all mine went, but very minor for the time being. The key bit occurs
whenever I hit that play button.

"sh: mplayer: not found"

That is the entire line in the log file. Every time I hit play.

What in the wild wild world of Batman did I do to screw that up?
Should I install mplayer? Did I somehow uninstall it? I didn't do it
intentionally. No history of removing it in the apt file either.

I am guessing it might be old data in the database that I somehow goofed
up (I did, dump and restore the database at one point hoping to "start
over"). I don't know for sure, but this is no where close to being right.

None of the videos play regardless of file type. I even installed every
gstreamer codec I could find in the ubuntu repos on the remote frontend.
Still the same error.

I swear I have seen this problem on the list, but I am not finding it.

Problem #2

Earlier I stated I had weird issues with the display on my frontend.
Well part of the issue is that I can only get the TV to work right with
the NVidia drivers and my 9400GT. Without them, I get nothing after the
BIOS screen. However, the drivers will only let me get a 1024x768
picture. The old video card can't do VDPAU but it is also a NVidia card
and it displayed 800x600 rather well. The new card gives a _really_
blurry image of 800x600. Several times, I really hosed up the display
and had to reset it (hurray for ssh X forwarding!).

I don't mind the 1024x768 resolution, but I easily lose 20 pixels on
every edge of the screen. Normally with Mythbuntu on the Desktop, there
is an Applications menu in the top right. I can't see it at all. When I
click to see the menu, I see half of the first item. None of the icons
or first letters of the menu items can be seen on the left side of the
screen. I probably wouldn't care (cause I rarely use the desktop on the
frontend), except that one of the shows I had recorded has subtitles.
The subtitles are in such a position that it is hard to read with half
the bottom line of text missing...

In my stupid-fu googling last night, I discovered I can change this
through Utilities/Setup->Setup>Screen Setup Wizard. So I moved both
arrows to the point I could see them both in each corner and I saved. It
shrunk the mythtv display alright, and shoved it back up into the top
right. Figuring I did something wrong, I tried again. Even worse.

Had I read the mythtv doc guide last night, I would have known better.

Right now, no matter what I do, I can't expand. I can only shrink it
further. I only have about 3/4 of the screen usable by mythtv.

I have now spent over 2 hours on these two problems alone today and I am
not progressing. Everything else I have fixed or in the process of
reading the documentation on. I would greatly appreciate any input and
advice that will help me fix whatever I have done to my myth box.

Thank you for reading through all of that to help me!

Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the mythtv-users mailing list