[mythtv-users] Using "jump mainmenu" starts livtv

Dale E. Pontius DEPontius at edgehp.net
Thu Apr 1 19:22:30 UTC 2010

I'm trying to appliance-ize my mythfrontend, and currently that means
making it respond "correctly" to the power button on the remote.  For
faster response, I'm using suspend-to-ram instead of powering off.  I've
hung this on a kill-o-watt, and find that there just isn't much
difference between the two, unless you use the power supply switch to
really turn it off.

The system is already set to wake-on-usb, so pressing the power button
on the remote brings it back up.  On the other side, when I press the
power button if it's running, I'd like it to jump to the main menu, then
suspend-to-ram.  I've seen before that it can be "rude" to the server to
suspend while something is running, particularly livetv, that chews up
both a capture card and disk space.  I've heard that more recent
backends are smarter, and will drop the resources of a frontend that
disconnects.  But that could use verification, and I'd still like to run
clean, and the cleanest way is to be at the main menu when the system wakes.

But that's not what happens.  I've mapped CTRL+H to jump-to-main-menu,
and when I do that, either with the keyboard or the remote, it first
goes to the main menu, then goes to live tv.  (The worst possible spot
from a resource point of view, of course.)  I wondered if I was stepping
on a previously-bound key, so tried ALT+H, with the same results.

Does anyone understand why jump-to-main-menu would get me there, then
start livetv, and how I stop the latter?

I've been using this reference: Two actions off one lirc keypress?
to get where I've gotten so far, and have another question along this
line.  I'd like to make the power button work correctly too.  Again, all
is well on the turn-on side - the power button wakes the machine
properly.  I've done nothing on the turn-off side, but I suspect that
with acpid installed, the normal power button action would be to power
the machine down.  Changing that to suspend-to-ram is easy, but I'd also
like to again, tell mythfrontend to jump-to-home.  The "two actions"
reference also talks about using netcat to send commands to port 6546. 
I've checked, and on my machine mythfrontend doesn't bind to 6546 - it
binds to 6545, 6547, and several other ports.  I know that using netcat
to send a command to 6547 doesn't work, and I haven't yet tried 6545 or
the others.  Can anyone comment on this, or is there another way to send
commands to mythfrontend from a script?

Dale Pontius
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100401/00b1b99a/attachment.htm>

More information about the mythtv-users mailing list