[mythtv-users] Zotac ION and wake-on-USB

Chad Voelker chad.voelker at gmail.com
Thu Oct 1 17:37:31 UTC 2009

On 09/30/2009 08:00 AM, mythtv-users-request at mythtv.org wrote:
> Date: Wed, 30 Sep 2009 02:18:54 -0700 (PDT)
> From: Steve V<olivuts at yahoo.com>
>> >  My Zotac has the JP3 USB power jumper, and from what I've read it
sounds like
>> >  the board should work with wake-on-USB.  I've tried the jumper in both
>> >  "5Vdual" and "5V" positions, but the behaviour I get is that when I
enable USB
>> >  wakeup events in the OS, and try to suspend.... the system suspends,
>> >  immediately boots again.  I'm fairly sure I've read about people
>> >  wake-on-USB to work under Windows.... but I haven't seen and
pronouncements of
>> >  success under Linux.
>> >
>> >  I've thought one of my next steps would be try one of those USB
flashlights to
>> >  verify that I do actually have power on the USB port when the system
>> >  suspended, and assuming I do have power....  embark on a heavy session
>> >  googling.   However, the system is fairly light on power usage anyway,
>> >  solving this is lower on the priority list than some other tasks.
>> >
>> >  Has anyone else gotten this board to work with wake-on-USB?
> Yes i have mine working. I can't give you a lot of info to help though. I
have Mythbuntu 9.04 installed and it just worked.


I had this problem and solved it yesterday with my Dell Latitude d630
running Ubuntu. My symptoms were this: with any USB device plugged in, the
system would go into suspend, then immediately come out. Removing the USB
device made it stay suspended until I pressed the power button. It sounds to
me that your USB ports are getting power properly.

What I did to resolve it was disable all of the USB entries in
/proc/acpi/wakeup which allowed the USB device to be plugged in while
suspended. I then enabled the USB entries one by one until the USB device
brought the PC out of suspend properly. To toggle the entries in this file,
just do the following (as root): echo USBX > /proc/acpi/wakeup    (where X
is one of the USB IDs in the file)

Good Luck.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091001/5a4468f3/attachment.htm>

More information about the mythtv-users mailing list