[mythtv-users] [ATrpms-users] Updated from fedora 10 to 12 and have issues with nvidia driver loading

Paulo Cavalcanti promac at gmail.com
Sun Nov 29 09:54:49 UTC 2009

On Sat, Nov 28, 2009 at 10:39 PM, O&M Ugarcina <mo.ucina at gmail.com> wrote:

> Hello Guys,
> I have just done a Fedora 10 to Fedora 12 upgrade myself . Tried with
> preupgrade , as I did on my other machine , but on my mythbox it failed .
> Tried it twice but it failed both times just after the reboot phase saying
> something like preupgrade has encountered a unexpected failure etc... So
> then I had to go with the yum method . With the yum method because of the
> changes to the rpms done in fedora 12 , I could not go to 12 directly ,
> needed to go to 11 first . Going to 11 was smooth , just needed to remove
> Numeric due to dep issues . Once at 11 could not get nvidia to come up and
> had to blacklist nouveau  and remake the inittrd . Tried preupgrade again ,
> but it failed at exactly same spot as before . Then did yum upgrade again
> from 11 to 12 . The only dep issue was tigervnc that I uninstalled and once
> at 12 put back in again . With fedora 12 I had a bit of an issue with nvidia
> not starting up . I thought that it was our nouveau friend again , but it
> turned out that the kernel had run out of memory and I had to vmalloc some
> more , to be on the safe side I doubled the initial allocation and set
> vmalloc to 256M . I guess there is more stuff to load in fed 12 . The only
> thing that has stopped working for me on fed 12 is spdif sound , but that is
> a subject for another thread .
This is a different subject, but  this message is related to your sound
problem, I guess:


I have exactly the same problem. Fedora 12 clean install and no analog sound
in myth.
Everything had sound but myth. In your case is the spdif,
but maybe the solution still applies.

This is how I got my sound back:

1) I added to /etc/asound.conf


# Place your global alsa-lib configuration here...

@hooks [
        func load
        files [
        errors false

2) I added to my ~/.asounrc

pcm.nopulse {
    type hw
    card 0

ctl.nopulse {
    type hw
    card 0

3) I used ALSA:nopulse for *sound* and mixer devices in mythfrontend setup.

4) In mythsetup, I have to use /dev/dsp for my capture card. Otherwise,
I cannot change channels (live tv aborts). This implies in uncommenting
the single line in dist-oss.conf and rebooting.

I hope this helps.

Paulo Roma Cavalcanti
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091129/a55ce4c5/attachment-0001.htm>

More information about the mythtv-users mailing list