[mythtv-users] HD-PVR: Encoding Errors Running 0.22

Jeremy Thornhill jeremy.thornhill at gmail.com
Fri Nov 27 18:11:11 UTC 2009

On Wed, Nov 25, 2009 at 1:45 PM, Jeremy Thornhill
<jeremy.thornhill at gmail.com> wrote:
> I've tried to replicate the failures using 'cat' but I've never had a
> problem that way. It could just be I've never tried this at the right
> (wrong) time.

So, I do not think that my problem is with MythTV. Despite what I said
above, I *can* replicate the errors using cat.

I believe the 'device not running' stuff is MythTV's signal monitor
detecting that the HD-PVR hardware decided to stop recording. I don't
pretend to know the details of why, but it seems that sometimes the
hdpvr just mysteriously fails, and when mythtv detects this it tells
the HD-PVR to start recording again.

So, those 'gaps' that people are seeing are spots where the hd-pvr is
cutting out. Once mythtv restarts the device, the recording picks back

I'm horribly perplexed by my situation though. My device seems to just
arbitrarily fail to start recording properly - once it's started, it's
fine. The first time I start recording with it after a boot, it's
fine. But after that it's a total crap shoot. Sometimes the next
recording is fine, sometimes it will fail 2 times and then start,
sometimes it will fail 20 times in a row!

Even more bizarre, if I rmmod/modprobe the hdpvr module, it will
always record properly immediately thereafter.

I'm at a loss. Is my hdpvr defective? Perhaps something subtle is
wrong with my kernel config? The debug messages from the hdpvr module
tell me almost nothing. I'm wondering if I could patch the mythtv
source to rmmod / modprobe the module when a signal error is detected,
as that seems to almost always resolve my problems.


More information about the mythtv-users mailing list