[mythtv-users] HD-PVR as IR receiver under Mythbuntu, advice needed

Jerry Rubinow jerrymr at gmail.com
Tue Nov 24 22:49:52 UTC 2009

On Tue, Nov 24, 2009 at 5:13 PM, Jarod Wilson <jarod at wilsonet.com> wrote:

> On Nov 24, 2009, at 4:58 PM, Jerry Rubinow wrote:
> > > There are reports of the unit essentially locking itself up during
> recording if the ir part is being polled by the lirc_zilog driver, yes. Not
> sure if that's an issue with the hdpvr driver or the lirc_zilog driver at
> this point. I don't actually use my hdpvr for much of anything at the
> moment, and haven't had time to dig into it.
> > >
> > > Hmmm.  Does use of the HD-PVR receiver necessitate use of lirc_zilog?
> >
> > Yes.
> >
> > > Is lirc_zilog always polling the IR?
> >
> > If loaded and bound to the hdpvr, yes.
> >
> > > Is there any way to prevent polling,
> >
> > Don't load lirc_zilog, or rewrite lirc_zilog to be interrupt-driven. (Not
> even sure if that's possible... It'd definitely be preferred if it was
> though).
> >
> > > and what implications does that have?
> >
> > Non-functional IR receiver. If you're not polling it, you're not going to
> see any incoming IR signals.
> >
> > Sounds like it's unknown whether this lockup affects all HD-PVR+lirc
> users or what the frequency is, or when you'll have time to look into it.
> Correct.
> > Fair enough.  It's not the answer I was hoping for, but better than no
> answer.  I still think I'll go ahead and get the Revo, and if I experience
> the same thing and it isn't too hard, I'll try to help debug it.
> Any and all help doing so would be much appreciated. However, at the
> moment, I'm not quite sure where to start, other than running both the hdpvr
> driver and lirc_zilog driver with full-blown module debugging options
> enabled.
> > When you say "non-functional IR receiver", do you mean the driver isn't
> functioning or the hardware/firmware?  Or unknown?
> The driver has to poll the IR chip to see if a new signal has arrived. If
> it doesn't poll the IR chip, you'll never know that a button was pressed,
> rendering the receiver non-functional.

I mean to say, do you mean the problem is that the lirc driver stopped
polling or the box stopped responding to the polls.  It sounds from your
first comment though that you don't have enough data to say which it is.

I'll be happy to compile both drivers with debug info.  It'll likely be a
week or three before the hardware gets here and I have everything to the
point where I can do that.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091124/4dcdc813/attachment.htm>

More information about the mythtv-users mailing list