[mythtv-users] Why does mythtv responds to lirc when in the background?

Tom Dexter digitalaudiorock at gmail.com
Tue Nov 24 14:41:34 UTC 2009

On Sat, Nov 21, 2009 at 9:13 PM, Paul Bender <pebender at san.rr.com> wrote:
> David Smiley wrote:
>> Hello everyone.  I have the latest 9.10 based mythbuntu based setup with
>> an lirc configuration copied from my previous setup which was based on the
>> http://wilsonet.com/mythtv/  (FC6)
>> There are a couple problems I have with my setup:
>> 1. mythfrontend doesn't respond to my remote control for the first two
>> minutes or so from having launched it.  The keyboard works.  This isn't a
>> big deal but is odd; it wasn't like this on my former setup.  When I look in
>>  mythfrontend.log I see that mythtv successfully initializes LIRC right away
>> on startup.
>> 2. I have recently been having fun with Boxee to get content that I don't
>> get on cable.  However if mythfrontend is still running (in the background
>> of course), it responds to all of my remote control presses.  How shall I go
>> about troubleshooting/fixing this problem?
> LIRC input is not inherently focus aware. Whether or not an application
> responds to LIRC input sent (based on lircrc's porg) to the application
> depends on the application.
> I use Hulu Desktop. I launch it using the EXEC action from a Myth menu item.
> I launch it using EXEC as Myth ignores LIRC input while something launched
> using EXEC is running.

What prevents MythTV from reacting to the remote when I play something
via (for example) xine from mythvideo?  Does myth intentionally stop
using the lirc socket while running an external program?  The question
never occurred to me until reading this thread.

Just curious.


More information about the mythtv-users mailing list