[mythtv-users] multiple mythfrontends on same computer

Erez D erez0001 at gmail.com
Tue Nov 24 09:07:39 UTC 2009


i have a computer which runs mysql, mythbackend and two instances of
mythfrontend (for two TVs)

i work in this configuration for around 5 years...

now that i upgraded to karmic, i had a lot of problems.
i fixed them one by one, and now i got to the issue of not being able to run
two frontends on the same computer at the same time

i run directly mythfrontend.real (as two instances of frontend were disabled
in the wrapper script)
i run the two instances from two different users, and different
"LocalHostName" in the users's ~/.mythtv/mysql.txt

it seams that the first instance i run works, the other doesn't.
the log file i get on the second is:

2009-11-24 11:06:01.781 mythfrontend version: branches/release-0-22-fixes
[22594] www.mythtv.org
2009-11-24 11:06:01.781 (old)Settings::ReadSettings(settings.txt) - No such
2009-11-24 11:06:01.781 Using runtime prefix = /usr
2009-11-24 11:06:01.781 Using configuration directory = /home/myth2/.mythtv
2009-11-24 11:06:01.781 UPnp - Constructor
2009-11-24 11:06:01.781 MediaRenderer::Begin
2009-11-24 11:06:01.781 ThreadPool:AddWorkerThread - HTTP_WorkerThread
2009-11-24 11:06:01.781 HttpServer() - SharePath = /usr/share/mythtv/
2009-11-24 11:06:01.781 MediaRenderer::HttpServer Create Error

any idea ?


mythtv 0.22.0+fixes22594-0ubuntu1
ubuntu karmic 9.10 64 bit
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091124/52613635/attachment.htm>

More information about the mythtv-users mailing list