[mythtv-users] Fan speed control using lm-sensors doesn't work. Help, please. -- SOLVED

Allen Edwards allen.p.edwards at gmail.com
Mon Nov 23 15:36:14 UTC 2009

On Sat, Nov 14, 2009 at 10:13 PM, Allen Edwards
<allen.p.edwards at gmail.com>wrote:

> I just searched the last year of posts and find nothing discussed on the
> problem I am having with lm-sensors.  I have a AMD 5400+ on an M3A Asus
> mother board.  We have been living with a very noisy CPU fan so today I
> finally got around to doing something about it.  First, I got a new heat
> sink, a Thermaltake TR2-R1 and it is a big improvement.  I checked the temp
> with sensors and it runs about the same, about 30 idle and 40-45 under load.
>  (The bios reports over 50c on boot up.  What's up with that?  I guess an
> error in the bios).
> The problem is with trying to get lm-sensors to work.  I installed all the
> programs and got as far as running pwmconfig.  All looked good, it
> controlled the CPU fan and did a detailed profile.  It got very quiet at a
> setting of 180.  But when it got to the part about testing what setting will
> not start the fan, it didn't change the fan speed.  And when I created the
> fancontrol file and re-booted, the fan is always at max speed, which is
> 1400RPM.
> So one level of the program controls the fan speed, but when it comes down
> to it, something is different and the fan speed is not controlled.  I should
> point out that this fan has 3 pins and not 4 so that may be part of the
> problem but the fan was being controlled by the first part of pwmconfig so I
> don't understand what is going on.
> Any help out there?  I would greatly improve the WAF if I could get that
> fan down to about 1000RMP when the CPU is at 1000GHz and doing nothing.  I
> don't care how loud the fan is when we are watching something because the
> sound of the show covers it up.
> Anyone understand what I am doing wrong?
> Allen
 I solved this problem.  The version installed on my mythbuntu system with
"apt-get install" was version 3.0.  this version does not work.  The latest
version is 3.1  I downloaded that version from the lm_sensors web site.

Unzipped it: tar xvjf <file>
cd to the new directory
used apt-get install to install the dependencies listed in the INSTALL file
make clean (in case you had some false starts)
make all
make install
I already had a sensors-detect file so did not have to repeat that
Ran "watch sensors" in one windows to monitor what is going on
ran pwmconfig in another window
installed /usr/local/sbin/fancontrol in the place I use to start files and
re-booted to test things.

Hope this helps the next person with this problem.  The fan is now so quiet
you can't hear it.  When Myth is doing something, it speeds up but usually
you are watching something to that masks the noise, which wasn't much with
the new fan-heatsink anyway.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091123/b45dc9f4/attachment.htm>

More information about the mythtv-users mailing list