[mythtv-users] HD-PVR: Encoding Errors Running 0.22

John P Poet jppoet at gmail.com
Sun Nov 22 17:17:45 UTC 2009

On Sun, Nov 22, 2009 at 2:15 AM, Alan Young <ayoung at teleport.com> wrote:
> Mike Smith wrote:
>> Hi,
>> I've been trying to track this problem down for a week now.  When I record
>> a regular
>> program like Monk, or The Big Bank Theory,  the Hauppauge 1212  does an
>> excellent
>> job.  But, when I try to record sports programs,  like a live NFL Football
>> game,  I get jumps.
>> While viewing, it looks like a quick jump over from 1 - 3 seconds.  I has
>> also happened
>> while recording Saturday Night Live ( SNL ).
>> Last night,  I upgraded the firmware on the HDPVR to 0x12, which posts to
>> this forum indicate
>> is the latest.
>> I also upgraded the kernel on my Fedora 10 backend to the latest supported
>> kernel,
>> The problem is on the recording side.  Not playback.  If I replay in Edit
>> Mode, and can
>> do a frame-by-frame advance, and the skip is still in the same place.  The
>> frames never
>> make it to the output file.
>> The mythbackend logs have these type of messages in the area where a skip
>> occurs.
>> These were from recording ESPN News.  The video was a replay of an
>> basketball game
>> where a player was being interviewed and a replay of his dunk was on the
>> screen.
>> What do these messages indicate?
>> 2009-11-21 03:30:08.598 Started recording: ESPNEWS: channel 3305 on cardid
>> 6, sourceid 2
>> 2009-11-21 03:30:36.763 DevRdB(/dev/video0) Error: Poll giving up
>> 2009-11-21 03:30:36.767 MPEGRec(/dev/video0) Error: Device error detected
>> 2009-11-21 03:30:36.769 DevRdB(/dev/video0): Stop(): Not running.
>> <======   Basketball replay here
>> 2009-11-21 03:31:48.552 DevRdB(/dev/video0) Error: Poll giving up
>> 2009-11-21 03:31:48.560 MPEGRec(/dev/video0) Error: Device error detected
>> 2009-11-21 03:31:48.561 DevRdB(/dev/video0): Stop(): Not running.
>> <=======    End Jump
>> 2009-11-21 03:32:09.697 DevRdB(/dev/video0) Error: Poll giving up
>> 2009-11-21 03:32:09.704 MPEGRec(/dev/video0) Error: Device error detected
>> 2009-11-21 03:32:09.704 DevRdB(/dev/video0): Stop(): Not running.
>> 2009-11-21 03:32:48.376 DevRdB(/dev/video0) Error: Poll giving up
>> 2009-11-21 03:32:48.380 MPEGRec(/dev/video0) Error: Device error detected
> Well, at least I'm not alone.  I was beginning to think I was as I not
> found any posts about this issue.  :)
> I've seen the on a variety of different channels over the last month or so.
>  It seems to work ok if I record with outside of mythtv with  cat
> /dev/hdpvr > file.ts.  It also seems work if I watch while it records
> (that is as long as VDPAU doesn't give an error, but that's another
> issue...).  It would be nice if it gave some more information as to what
> mythtv thinks detects the error as.  I've tried turning on hdpvr driver
> debugging and don't get much more there.
> I've tried switching cables and put the HDPVR on it's side to help
> ventalation.  But I still get the error.  I was running .21+fixes+hdpvr
> and as far as I can recall I did not see this problem until I moved up to
> trunk before .22 then .22RCs and later.
> I have a Athlon X2 4200 on a MSI K8NGM2-FID (nforce MCP51) board.  I'm
> recording from DirecTV.  What hardware are you running and what are you
> recording from?
> Alan

Out of curiosity, what else is happening on the computer when these
glitches appear?  What is the system load?  Are there any processes
consuming excessive amounts of system resources?

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?

More information about the mythtv-users mailing list