[mythtv-users] Device permissions

aaron memoryguy at gmail.com
Sat Nov 21 15:19:05 UTC 2009

On Fri, Nov 20, 2009 at 17:54, Rod Smith <mythtv at rodsbooks.com> wrote:
> I realize you've solved your problem in another way, but I thought I'd point
> out for your own future reference and/or for the benefit of others that

Aha! I got the video nodes to have 0666 permissions, finally... no
luck yet with LIRC (creating a "lirc" symlink) but I already solved
that a while ago by updating my script to make lircd look at lirc0
directly. :)


> upgrades your udev package (or whatever package has the default file). Many
> of Slackware's package management and system configuration procedures are
> different from those for most other Linux distributions, though, so I'm not
> sure if the general procedure of adding new, rather than editing existing,
> udev rules applies to Slackware.

Slackware is usually pretty good about not overwriting configuration
files that you modify/create yourself... famous last words... ;-)  It
looks like I should be safe adding my own rules to the directory...
Slackware's philosphy tends to be to stay out of your way and let you
do your thing.

> FWIW, the MythTV wiki has a section on udev, with examples tailored to the
> sorts of things MythTV users often need to do with udev:
> http://www.mythtv.org/wiki/Device_Filenames_and_udev

Maybe I'm getting old, but I always have trouble searching the wiki
and finding useful results :(   That could be why I didn't think to
look there first :/

(I still need to read through the full page, but so far your
explanation has really helped me to understand the magic udev
language... it doesn't feel quite as random as it had before :) )

Thanks again,

More information about the mythtv-users mailing list