[mythtv-users] Ticket #7610: MythTv 0.22 doesn't work with mysql 5.1.41

Michael T. Dean mtdean at thirdcontact.com
Thu Nov 19 13:16:46 UTC 2009

<moving to the -users mailing list instead of the MythTV bug database>

On 11/19/2009 06:30 AM, MythTV wrote:
> #7610: MythTv 0.22 doesn't work with mysql 5.1.41
> Comment(by pyther):
>  What needs to be done to fix this then? I am really kinda lost here.

You need to get a version of MySQL that was compiled properly.

If you're building from source, you can either use proper optimization 
(i.e. don't set -O in CFLAGS) or apply the changes Davin posted to the 
MySQL bug tracker (as mentioned at 
http://svn.mythtv.org/trac/ticket/6683#comment:6 ) or using 
-fno-strict-aliasing (as he mentioned in the MySQL bug report).

If you're using packages, get your packager to fix it.  You might want 
to direct your packager to Davin's comment at the link above.


More information about the mythtv-users mailing list