[mythtv-users] Major Audio Sync Issues

Paulin paulin at spextreme.com
Thu Nov 19 01:29:11 UTC 2009

On Wed, Nov 18, 2009 at 5:24 PM, Paulin <paulin at spextreme.com> wrote:

> On Wed, Nov 18, 2009 at 3:13 PM, Mark Greenwood <fatgerman at ntlworld.com>wrote:
>> On Wednesday 18 Nov 2009 02:08:05 Paulin wrote:
>> > I'm been banging my head against the wall on this issue for a couple of
>> days
>> > now.  I've search the thread and google for anything I can find on Audio
>> Out
>> > Of Sync and I've tried a ton things.   No luck with any of it.
>> >
>> > I upgrade last week to Mythbuntu 9.10 (myth 0.22).  I'm using VDPAU.
>> > Before upgrading I didn't really have this issue.
>> >
>> > When I say upgraded I basically wiped the disk and started fresh.
>> >
>> > Anyway now the Myth Recordings that are occurring seem fine.  However
>> when
>> > playing back the audio and video become out of sync.  I've noticed that
>> the
>> > video will attempt to slow down to let the audio catch up but it never
>> stays
>> > there.  They get out of sync and evenytually get really bad (few
>> seconds).
>> >
>> > I've tried changing the player to VLC, I also tried the suggestion on (
>> >
>> http://mythtvbox.blogspot.com/2006/01/fixing-mythvideos-audiovideo-sync.html
>> )
>> > and put oss on the mplayer command string.  I also setup XvMC per the
>> wiki
>> > page.  Didn't change anything.
>> >
>> > My first question is, how do I enable extended logging on myth frontend
>> > using mythfrontend.real.   I remember something about adding the
>> parameter
>> > 'playback' but not sure how to do that with mythfrontend.real.
>> >
>> > Second why is my audio/video so out of sync? How do I track down the
>> problem
>> > and fix it.
>> >
>> > Thanks
>> > steve
>> >
>> Have you tried enabling the setting 'Use Video As Timebase', somewhere
>> amongst the reams of setup screens, TV playback I think? I did this for a
>> similar problem, also with VDPAU, and it solved it.
>> Mark
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
OK well here is an updated.

Use Video as time base causes the video to slow to a crawl and play really
weird.  I have Enable RealTime checked, Extra Audio Buffer check ,and warn
on no audio.  I'm using VDPAU SLIM.

It seems to happen mostly with recorded programs but not all. and
not consistently.  When the problem occurs, I've seen the video slow down
while the audio catches up.  I've also seen where the mouths talking is out
of sync with audio.  Last night watching Castle and V was the worst.  At
some points the video was 3 to 4 seconds out of sync.  Commercial skipping
causes it to get closer.

I did see the problem watching through myth video but that wasn't too bad
(half  second off).

Also processing power of the node when watching a program is about 8% CPU
usage.  Commercial flagging running would spike around 70% (62% flagging).
 Recording also going on.  So processing wise it should be safe (2.2ghz dual

So what have I tried,
Different players and player options (mplayer, vlc).
Playing the video elsewhere (copied mpg to a windows machine played fine)
Played with xorg.conf but didn't change anything.
Host of other little things here and there as I found online.

On a possible related note, I have the following issues occur and I'm not
sure if it could be hardware/configuration/or NVidia driver.
- While watching a video or recording, the screen just goes blank.   Audio
continues but there is no picture.  Like the TV lost the signal.  I have to
restart GDM to get it back up.
- Sometimes after restarting GDM it comes back up and the entire picture is
distored.  Like each line (pixel row) is skewed (if that is the best
description) so the entire picture is impossible to determine.  At one point
I went to the desktop and popped up the NVidia config.  It looked like
normal but if I moved it, it became pixellated (like using photoshop's noise

So any ideas or ways to fix this.  I didn't have these issue in the Myth
0.21 that I built from trunk. So I think everything (hardware) should be

I'm desperate and frustrated so I'm willing to try any ideas to fix this.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091118/1189435a/attachment.htm>

More information about the mythtv-users mailing list