[mythtv-users] Implementing HD-PVR IR Blaster

Bobby Schwartz rschwartz at lastar.com
Tue Nov 17 13:47:51 UTC 2009

>>> make CONFIG_LIRC_ZILOG=m -C /lib/modules/kver/build M=$PWD modules
>> Hey! Thanks for the response!
>> That did the trick.  I now have built modules.  I'm running Mythbuntu
>> 9.10 (kernel 2.6.31.)
>> I ran these two commands to install the modules that (I think) had
>> changes in them...
>> insmod lirc_dev.ko
>> insmod lirc_zilog.ko
>> I saw no errors.  I can see lirc_zilog in lsmod and dmesg said
>> "lirc_dev: IR Remote Control driver registered, major 251"
>> Sadly I'm away from home and the HD-PVR is powered off so I can't
>> much further than this.  If everything is working I should see a new
>> lirc entry in /dev, correct?
>That only gets created when the driver loads up and binds to an actual
device. Since your HD-PVR isn't on, lirc_zilog >found nothing to bind
to, so you get no /dev entry at the moment. Not sure if it'll bind
automagically when you power >it on, or if you'll need to reload it...
>Jarod Wilson
>jarod at wilsonet.com

So I got compiled and snapped in the modules.  I tried several
combinations of modprobing and connecting the HD-PVR.  Dmesg shows the
lirc_dev module loading "lirc_dev: IR Remote Control driver registered,
major 251" and I see in dmesg the HD-PVR loading...

[   10.181882] hdpvr 1-4:1.0: untested firmware version 0x12, the driver
might not work
[   10.562303] hdpvr 1-4:1.0: device now attached to /dev/video0
[   10.562332] usbcore: registered new interface driver hdpvr

But I'm not seeing any new lirc devices in /dev.  I also bounced the box
for grins and giggles.

More information about the mythtv-users mailing list