[mythtv-users] QT Library error after .22 install

Don B mythlist at bossung.net
Sun Nov 15 16:08:26 UTC 2009

-------- Original Message --------
Subject: Re: [mythtv-users] QT Library error after .22 install
From: Paul Bender <pebender at san.rr.com>
Date: Fri, November 13, 2009 7:01 pm
To: Discussion about mythtv <mythtv-users at mythtv.org>

Don B wrote:
> I have a fresh install of CentOS 5.4. I followed the howto in the wiki 
> to install mythtv on CentOS. All goes fine during each stage of the install.
> The first time I start any myth related program (backend, setup, 
> frontend etc) I get the following error:
> Starting mythbackend: /usr/bin/mythbackend: symbol lookup error: 
> /usr/lib/qt44/lib/libQtWebKit.so.4: undefined symbol: 
> _ZN24QXmlStreamEntityResolver13resolveEntityERK7QStringS2_
> Any ideas on how to fix this?

>You may need to make sure that you are not picking up RHEL/CentOS Qt4 
>libraries when you do the install.
>When I did the update to Myth 0.22 on CentOS 5.4, it installed some of 
>the qt4 libraries from RHEL/CentOS rather than the qt44 libraries from 
>ATrpms. Once I exclueded the qt4 libraries by adding (qt4 and qt4-* to 
>the exclude variable in /etc/yum.conf) and removed any qt4 packages 
>(found using rpm -qa | grep qt4), the yum update picked up the qt44 
>versions of qt and qt-mysql and everything was fine.
>mythtv-users mailing list
>mythtv-users at mythtv.org
Thanks Paul, this did the trick. I updated the CentOS install wiki page
to reflect your addition to make this work.

More information about the mythtv-users mailing list