[mythtv-users] mythfronte crash after upgrade to 0.22

Michael T. Dean mtdean at thirdcontact.com
Sat Nov 14 19:05:39 UTC 2009

On 11/14/2009 01:58 PM, Mitko Haralanov wrote:
> I just upgraded my myth box to 0.22 (MythDora 10.21 + latest RPMs
> from rpm-fusion via 'sudo yum update'). The update went fine and after
> that rebooted.
> After the reboot, the machine came up fine and when autologin started
> mythfrontend, it notified me that I need to run mythtv-setup to upgrade
> the database.
> I quit mythfrontend, stopped the backend, and ran mythtv-setup. In
> there I added the new Storage groups setup and quit.
> After restarting the backend, I tried to start the frontend. I started
> upgrading the database schemas and then it crashed with a 'Floating
> Point Exception'. After that every attempt to run it results in the
> same crash.
> I have tried dropping all MythMusic related tables so the frontend can
> recreate them but that did not help at all. I can't find any
> information on this problem at all.

Can you restore your 0.21-fixes backup, then start mythtv-setup, then 
start mythbackend, then start mythfrontend and capture mythfrontend log 
files when it attempts to upgrade the schema and fails with the floating 
point exception.  The logs you're getting now are useless in tracking 
down the failure since they don't even show which schema is broken/where 
to start looking for a bug.

Then, please attach the complete log file to a message to here.


More information about the mythtv-users mailing list