[mythtv-users] AudioPulseUtil: Failure to Suspend in MythTV 0.22

Mike Smith easygreenus at yahoo.com
Sat Nov 14 06:10:51 UTC 2009


I am upgrading my frontend and backend systems from 0.21 to 0.22.
They have been running reliably since 0.21 came out.  I upgraded to
0.22 tonight.  The backend is running fine.  But,  when I try to run
mythfrontend on the client I get:

[mythtv at mythtv ~]$ mythfrontend
2009-11-14 00:49:07.964 mythfrontend version: branches/release-0-22-fixes/mythtv/ [22759] www.mythtv.org
2009-11-14 00:49:07.986 AudioPulseUtil, Error: Failure to suspend: Invalid argument
2009-11-14 00:49:07.987 AudioPulseUtil, Error: Failure to suspend: Invalid argument
2009-11-14 00:49:07.987 ERROR: ***Pulse Audio is running!!!!***
2009-11-14 00:49:07.987 ERROR: But MythTV was not able to suspend it. EXITING!

I am running Fedora Core 10 ( FC10 ).

I had trouble doing the upgrade.  I have 0.21 installed and I got a lot of messages about conflicting
files ( both on backend and frontend upgrade ).  I ended up removing all of the 0.21 rpms and
did the upgrade ( or installation at this point ),  with yum install mythtv-suite

If I kill pulseaudio,  mythfrontend will come up on the client.
I can watch  previously recorded videos,  but there is no sound.
I can look at the Program Guide - so connections to the DB are good.
I can "Watch TV", but again, no sound

I've looked through the archives.  I see several users with pulseaudio problems,  but, 
they were all with the DEV versions of MythTV and had to do with problems
the suspend and restore of pulseaudio was causing them.  Nothing about
not being able to suspend it.

Thanks for your help.



More information about the mythtv-users mailing list