[mythtv-users] Mythvideo - disabling storage groups

Robert McNamara robert.mcnamara at gmail.com
Fri Nov 13 06:35:25 UTC 2009

On Thu, Nov 12, 2009 at 10:28 PM, Robin Gilks <g8ecj at gilks.org> wrote:
> Having just upgraded from 0.21-fixes to 0.22-fixes, I went through the
> instructions on the wiki to create all the new storage groups for
> Mythvideo.
> I then remembered that I have a few iso images so I deleted the video
> storage group and filled in a direct path on the Setup->videos->general
> page so that meta data would be accessed via the storage groups but the
> video file itself would be direct file access or via NFS on the frontends.
> Doesn't work - video browsing still thinks that it is using storage groups
> so I can't play anything at all, never mind iso images :-(

Put your ISO files in a different path than the SG files, and rescan
your videos. ie if your SG files are on the backend at /media/movies,
put the ISOs in /media/ISO, mount /media/ISO on your remote frontend,
set /media/ISO as the local video path, and scan your videos.  Now the
SG videos will be accessed via SG, and the ISOs will be accessed
"locally."  Or just remove the video Storage Group and go all

> So how do I disable the video storage group other than deleting it so I
> can play anything? And what is the failed to open /dev/dvd error all about
> when trying to play an iso image?

That would be the aforementioned "you can't play ISOs in Storage Groups."


More information about the mythtv-users mailing list