[mythtv-users] StartEncoding failed

Paul Bender pebender at san.rr.com
Mon Nov 9 19:42:02 UTC 2009

David Gabler wrote:
> All,
> Just started noticing this error on my backend but can not seem to figure
> it out.
> Upgraded to 0.22 and still having the same problem.  Hardware consists of
> a HP500 (video1-2) and HP150 (video0).
> Have removed and re-added tuners to no avail.
> target directory (/data/videos/tv) exists and has enough space.
> What I can see it all boils down to is :
> 2009-11-08 23:42:19.403 MPEGRec(/dev/video0): StartEncoding
> 2009-11-08 23:42:19.403 MPEGRec(/dev/video0) Error: StartEncoding failed
>                         eno: Invalid argument (22)
> 2009-11-08 23:42:19.404 MPEGRec(/dev/video0) Error: Failed to start recording

I am getting the same error on my Hauppauge PVR-250 cards (my HDHomeRun) 
works fine. In case there were relevant database entries that did not 
get deleted by deleting and re-adding the tuners, I tried dropping the 
mythconverg database and starting with an empty database (mc.sql). Still 
the problem persisted.

I am running my master backend on CentOS 5.4 with ATRPMS for IVTV and 
MythTV. The kernel package version is 2.6.18-164.2.1.el5, the IVTV 
package version is 2.6.18-164.2.1.el5-0.10.6-132.el5 (IVTV version 
0.10.6) and the MythTV package version is 0.22-220.el5 (MythTV 0.21 
fixes 22759). While the kernel is one minor version behind (current is 
2.6.18-164.6.1.el5), I do not see it causing the problem as the IVTV 
version did not change between these two kernel versions.

More information about the mythtv-users mailing list