[mythtv-users] Mysql problems upgrading to 0.22

Matt Beadon matt.beadon at gmail.com
Sun Nov 8 06:32:55 UTC 2009

So I took the plunge last night having read all the wiki's and suggestions I
could find (too bad I jumped before the official 0.22 release).  :)

First my mythtv background:
I started playing with 0.21 on debian lenny around last Feb having used
debian for many years.  Around March I had it setup and stable enough to
replace our ageing ReplayTV (RIP).  A month ago I changed the OS to ubuntu
9.04 (in large part because of all the mythtv/ubuntu users on this list and
its similarity to debian).  I enabled the 0.21-fixes+vdpau repos from JYA
(thx!) and let that settle waiting for 9.10 and 0.22.  On thursday I did a
dist upgrade to 9.10 and then friday night I enabled JYA's testing repo and
moved from 0.21-fixes+vdpau to 0.22-fixes-22750.

The package upgrade was fine but when I loaded up mythtv-setup for the first
time it tried to upgrade my DB schema and failed.  I couldn't find the error
so I tried running it again and had similar results.  Fearing that my DB
would be corrupted I dropped it and restore a backup copy.  Same problem
again, this time I caught an error in the mythtv-setup console that said a
perl script was missing (I think it
was /usr/share/doc/mythtv-backend/contrib/database/mythconverg_backup.pl)
but it still managed to create another mythsql.backup so I don't think that
was the real problem.  The real error appeared to incompatibility in the
"people" structure in the DB (stupidly don't have the clue that pointed me

I stumbled on the following:
http://www.gossamer-threads.com/lists/mythtv/users/399341#399341 in
particular "I went ahead and deleted the two lines in the SQL dump that
INSERT INTO `people`".  Figuring I didn't have much to lose I commented out
those two lines in my backup.sql, dropped the DB and restored from this new
mythsql.backup2.  From there everything went more smoothly.

Does anyone know why I had to dig that much into the DB just to upgrade the
schema?  I'm glad it only took me an hour or so to hack it but newbies are
going to be screwed by something like this.  Am I hitting some weird corner

Moving on from there I've got 0.22-fixes-22750 running on my system but
there are some niggling problems.

-mythweather no longer knows that I'm in San Jose and I cannot find anywhere
in the frontend to re-set that value?  Where did that setting go?
-similarly mythflix has lost my account/RSS feed info so it's blank and I
don't see where to set it (or why it disappeared in the upgrade)
-still trying to iron out appearance settings that will look ok on SDTV.
 Currently my text is hard to read and the "usual" pincushion on svideo is
maddening but that's nvidia analog tv-out...

Both mythweather and mythflix worked with 9.10 and 0.21-fixes+vdpau so it
was something about the 0.22 upgrade that caused them to crap out.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091107/825d87e8/attachment.htm>

More information about the mythtv-users mailing list