[mythtv-users] Mythbuntu 9.10 LCDServerHost able to edit in database?

Deyan mythtv at bektchiev.net
Fri Nov 6 23:31:09 UTC 2009

On Fri, Nov 6, 2009 at 2:10 PM, Paul Harrison <mythtv at sky.com> wrote:
> Michael T. Dean wrote:
>> On 11/06/2009 03:57 PM, Douglas Mackay wrote:
>>> 2009/11/6 Douglas Mackay:
>>>> 2009/11/6  steve.goodey:
>>>>> I wonder if someone can help me please.
>>>>> Can anyone give me a clue about editing the entry LCDServerHost in the
>>>>> database? From this post
>>>>> http://www.gossamer-threads.com/lists/mythtv/users/402902
>>>>> I need to change it to I have the userid and password
>>>>> for mysql
>>>>> but am unable to find the commands to allow editing of the required
>>>>> field,
>>>>> which does not appear to be editable in mythweb.
>>>> Thought it only me that had the problem. The LCDServerHost value might
>>>> not exist in you database (it didn't in mine).
>>>> In the settings table within the mythconverg database there are three
>>>> fields :- value, data, hostname so to add the LCDServerHost setting
>>>> you would create a new row with
>>>> value=LCDServerHost, data=, hostname=<think this can be set
>>>> to null to apply to all hosts or you can specify an individual host>
>>>> I used phpMyAdmin to insert the value to the settings table however
>>>> you you should be able use the mysql tools to do the same.
>>> If you don't have phpMyAdmin installed it's probaly easier just to use
>>> mysql. The following should work :-
>>> mysql -u mythtv -p
>>> <enter password>
>>> use mythconverg;
>>> insert into settings (value,data,hostname) values ('LCDServerHost',
>>> '', null);
>> Or better, use MythXML:
>> my_host=setyourhostnamehere
>> my_key=LCDServerHost
>> my_value=
>> wget -O result.xml
>> "http://localhost:6544/Myth/PutSetting?HostName=${my_host}&Key=${my_key}&Value=${my_value}"
>> (just change the value for my_host)
>> Mike
> This looks like a system config issue.  mythlcdserver will default to
> 'localhost' if no LCDServerHost setting is present since that's what 99%
> of users will want. So you need to fix you config so localhost resolves
> to as I believe it should.
> Paul H.

I'm not sure if this is a bug but with 0.21 I never needed this and
for me localhost resolves to however with 0.22 until I added
the property the frontend could not connect to the local LCDproc
daemon. The backend could still connect and was working properly the
whole time.


More information about the mythtv-users mailing list