[mythtv-users] SD to HD switch with HD-PVR - mythfrontend crashes

John P Poet jppoet at gmail.com
Fri Nov 6 16:20:51 UTC 2009

On Fri, Nov 6, 2009 at 7:25 AM, Gerald Brandt <gbr at majentis.com> wrote:
> Hi,
> I just installed .22 (mythbuntu).  I figured it would be a safer approach
> than upgrading.  I'm happy to report that it's all working well, except for
> a couple of small items.
> 1. Mythbuntu - what's going on?  I have half the features/plugins that 9.04
> had.  Where's my Apple Trailers?
> And now the one the emailis about...
> When I switch from an SD channel (Motorola 6200 locked to send 480p) to and
> HD channel (locked to 720p), I get a corrupt video display.  7 out of 10
> times, mythfrontend crashes, 1 out of 10 times, mythfrontend fixes itself
> and all is well, 2 out of 10 times mythfrontend goes back to a menu.
> I upgraded the drivers for my HD-PVR (dunno to what version though).
> Is there something I'm doing wrong?  Does anyone else have these issues?
> Motorola 6200 STB
> NVidia ION
> Mythbuntu 9.10
> MythTV 0.22
> Thanks,
> Gerald

Try putting a sleep at the end of your channel change script.  At
least one second, but possibly more, depending on how long it takes
your Motorola to stabilize on the new resolution.

You could also try the patches listed on the HD-PVR wiki page, but
even with them a 1 second sleep may be needed.

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?

More information about the mythtv-users mailing list