[mythtv-users] reverting database schema

Mike McMullin mwmcmlln at mnsi.net
Tue Nov 3 16:26:05 UTC 2009

On Tue, 2009-11-03 at 06:54 +0000, Nick Morrott wrote:
> 2009/11/3 Mike McMullin <mwmcmlln at mnsi.net>:
> > 2009-11-03 00:46:55.454 Connected to database 'mythconverg' at host:
> > localhost
> > 2009-11-03 00:46:55.456 The schema version of your existing database is
> > newer than this version of MythTV understands. Please ensure that you
> > have selected the proper database server or upgrade this and all other
> > frontends and backends to the same MythTV version and revision.
> How many different versions of MythTV have you (tried to) run?

  Before this started only the one.  I have tried to upgrade figuring,
well if the database is toast, then bite the bullet and do an upgrade,
as the version that I had been using had a bug in the archive path

> What is the output of `mythbackend --version` ?

Mike at P-733-Lin:~> mythbackend --version
Please include all output in bug reports.
MythTV Version   : Unknown
MythTV Branch    : branches/release-0-21-fixes
Network Protocol : 40
Library API      : 0.21.20080304-1
Options compiled in:
 linux release using_oss using_alsa using_pulse using_arts using_jack
end using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun
tv using_ivtv using_joystick_menu using_lirc using_opengl_vsync
eo using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw
ld using_glx_proc_addr_arb using_bindings_perl using_bindings_python
l using_ffmpeg_threads using_libavc_5_3 using_live
Mike at P-733-Lin:~>

Mike at P-733-Lin:~> rpm -qa | grep mythtv

> Do you have any mythconverg*.sql.gz files in your recordings directory?

  None, but I did shut mysql down, copy the /var/lib/mysql/mythconverg
directory, and then reinitialized the database as if it was a clean

  Frankly at this point I'd prefer to just run the latest release dl'ed
from the mythtv web site, then try and deal with a lost database, but it
seems that configure fails because it cannot locate the required
freetype files though freetype is installed on the system.  Googling
isn't much help, and the mythtv-users channel on IRC was looking at a
problem with mysql.

More information about the mythtv-users mailing list