[mythtv-users] Mythfrontend idle cpu consumption help

Brad Templeton brad+myth at templetons.com
Mon Nov 2 22:07:13 UTC 2009

On Fri, Oct 30, 2009 at 12:22:22PM -0400, jansenj wrote:
> >
> >
> > The MythBuntu theme is one of the more heavyweight themes. Try a few
> > of the other ones, MythCenter-wide and MythCenter work well for me
> > (for my HD and non-HD frontends, resp.) I do use the MythBuntu OSD
> > theme, it does use an intermediate alpha value which does consume
> > more resources than some of the other OSD themes, but I feel it's
> > pretty enough to justify the extra resource usage and my computers
> > happen to have the needed grunt.
> >
> > I did try MythCenter-wide (in fact thats what I originally saw the problem
> with), although, it is no longer being packaged for Ubuntu 9.10.  That being
> said, no matter the theme, it shouldn't be taking 15% of the CPU to sit
> unused on the first menu screen.

I have also been noticing this for a while.    I do use mythcenter but
I can't imagine why the theme would affect this CPU usage.  I mean
what is the theme *doing* when it is sitting on a menu?  Nothing is
being drawn or anything.

I have found much greater use of CPU by the more recent mythfrontends
over the last year in general.   For example, while my system would
get decent idle times playing HD content and run quietly, now the
computer is routinely heating up (and running the fan loud) with
nothing else on the machine sucking CPU except xorg and mythfrontend.
(ie. no mythcommflag, which was the only reason the fan would get
loud before, or perhaps a runaway firefox page.)

It may be that the bob 2x deinterlacer is now running when before it
would not run because it thought the frame rate of the HDTV was .01%
too slow to do 2x deinterlacers, but I am also seeing it on 720p that
used to run 60% idle.

Any thoughts?

More information about the mythtv-users mailing list