[mythtv-users] loading two sets of QT binaries into same process

Dan Wilga mythtv-users2 at dwilga-linux1.amherst.edu
Mon Nov 2 13:35:55 UTC 2009

At 7:28 AM -0500 11/1/09, Michael T. Dean wrote:
>On 11/01/2009 12:19 AM, David DeMan wrote:
>>so i got a mac mini and i have 0.22-fixes branch building correctly,
>>however when i try to run it, i get "On Mac OS X you might be loading
>>two sets of QT binaries into the same process"
>>has anybody else seen this? and if so does anybody have a fix for it?
>>cause it trys to run, but then it ends because of the QT binary
>You likely didn't properly uninstall the 0.21-fixes (or below) 
>version of Myth you were running.  Get rid of all its libraries, 
>plugins, etc. and then re-do the make install of 0.22-fixes.

I'm having the same issue. I am able to run MFE, but get this in the 
log repeatedly in Watch Programs. Settings screens and the like do 

I was under the impression, however, that the osx-packager.pl script 
assembles a completely self-contained binary. There aren't any 
libraries that get installed globally, since there is no "make 

Rather, I think the problem probably has to do with a conflict in 
versions of qt I've previously installed with fink and/or macports. 
The version of qt that's built-into the .app package should take 
precedence, but it isn't.
Dan Wilga                                                        "Ook."

More information about the mythtv-users mailing list