[mythtv-users] Issue with Multirec and DVB-S?

Nick Rout nick.rout at gmail.com
Sun Nov 1 23:22:33 UTC 2009

On Mon, Nov 2, 2009 at 11:47 AM, Ben Lancaster <mail at benlancaster.co.uk> wrote:
> Hi there,
> I'm currently recording something on an HVR-4000 hybrid card using the DVB-S
> tuner on ITV HD. When I launched Live TV, it started on BBC HD. I thought
> this was a little strange as I only have a single DVB-S tuner, and didn't
> realise that ITV HD or BBC HD were on the same multiplex (if DVB-S even has
> multiplexes?), so I'd have expected MythTV to switch to one of the DVB-T
> tuners on another card. I flicked around a few other DVB-S channels and
> noticed that they were all playing fine. So, I went in to my recordings and
> started watching the DVB-S recording on ITV HD to find that the recording
> stopped working at around the point I'd switched to Live TV - mythbackend
> still says it's recording ITV HD (and it's still flagged as "currently
> recording" in Watch Recordings) but it's impossible to play past the point
> that I started watching Live TV, and the total time counter doesn't
> increase. None of my other tuners were active at the time, only the DVB-S
> one.
> Here's what mythfrontend logs at the point that it reaches the "end" of the
> show that should be recording:
> 2009-11-01 22:42:42.911 NVP(i): prebuffering pause
> 2009-11-01 22:42:43.152 [h264_vdpau @ 0xb6c2d7c0]missing picture in access
> unit
> 2009-11-01 22:42:43.152 [ac3 @ 0xb6c2d7c0]incomplete frame
> 2009-11-01 22:42:43.152 [ac3 @ 0xb6c2d7c0]invalid frame size
> 2009-11-01 22:42:43.170 [h264_vdpau @ 0xb6c2d7c0]missing picture in access
> unit
> 2009-11-01 22:42:43.191 ~OpenGLVideoSync() -- closing opengl vsync
> 2009-11-01 22:42:43.305 Marking recording as unwatched
> 2009-11-01 22:42:43.305 TV: Attempting to change from Watching
> WatchingRecording to None
> 2009-11-01 22:42:43.306 TV: Changing from Watching WatchingRecording to None
> 2009-11-01 22:42:43.327 TV: Attempting to change from None to None
> Is this a bug that needs reporting, or an issue with my setup? I do have
> multirec set up on the DVB-S tuner, it looks like I probably shouldn't, but
> surely MythTV shouldn't have allowed me to have multirec setup on an input
> that doesn't support it?

I don't know the answer to your problem, but DVB-S certainly does
support multireac, and certainly does use multiplexes.

More information about the mythtv-users mailing list