[mythtv-users] Changing file-permissions and streaming local files not working

Markus Doits markus.doits at googlemail.com
Mon May 25 21:21:08 UTC 2009


I've got two problems which bother me for days now (well at least one of
them). But first my mythtv-version: I'm using mythtv 0.22 svn-20616 with
backend and frontend on the same machine.

I'm using Debian Sqeeze/Sid and the mythtv-backend runs as a user
"mythtv", the frontend as my regular user (could not get it work as the
mythtv-user with pulseaudio enabled, because user "mythtv" can not
suspend pulseaudio for some reason - another story).

Files (recordings) get saved on /mnt/recordings/mythtv, which is a local
mounted filesystem (ext4). user:group of this dir is mythtv:mythtv and
files created by the backend usually get permission 644. since my local
user is also in the group "mythtv", everything works well (so even a 640
would be enough). but here's the first problem: sometimes a file is
created with permissions 600. this happens to recordings, live-tv-files
and even transcoded files (.nuv). playing them in mythfrontend is not
possible and i have to chmod 644 them manually - which sucks having to
do so every time. i searched for that problem by google a few times
already and found only one post saying to restart mythtv-backend and new
files will again have 644. this works, until the issue happens again...
is there anything i can to to force permission 644 on newly created files?

just now i tried to check "always stream recordings from the backend"
(problem nr. two) which i thought would have the backend make accessing
the files and streaming it to the frontend - nevertheless i get the
output (mythfrontend)

2009-05-25 22:51:11.597 ProgramInfo, Error: GetPlaybackURL:
'17405_20090521210500.mpg' should be local, but it can not be found.

so it looks like the setting has no effect for me, because the frontend
still wants to access it - another bug?

anyway, my problem is to have files not being accessible by the
frontend, so is there any solution for this besides running the fronted
and backend as the same user? everything else on mythtv (great
vdr-suite!) works very well without major glitches like these ones, so
would be glad to have this annoyance squashed out.

thanks for you help,

More information about the mythtv-users mailing list