[mythtv-users] mythtv-setup crashes with segmentation fault or Illegal Instruction

Mark Knecht markknecht at gmail.com
Sun May 24 04:13:33 UTC 2009

On Sat, May 23, 2009 at 9:00 PM, Michael T. Dean
<mtdean at thirdcontact.com> wrote:
> On 05/23/2009 06:01 PM, Mark Knecht wrote:
>> On my new server I got past the mysql access problems and ONE time it
>> allowed me to run mythtv-setup. However now am seeing both
>> mythtv-setup and mythfrontend crash with a segmentation fault message,
>> and sometimes a message that just says 'Illegal Instruction'. I've
>> done simple things like restarting daemons and rebooting, etc. but
>> nothing so far has solved it.
> Illegal instruction generally means the program was compiled for a similar,
> but not quite right, architecture--for example, compiled for i686 but
> executed on an i486 (sorry, I can't give PowerPC equivalents because I don't
> know the family).  Sounds like a compile issue.
> Mike

Yeah, that was my thought also. Since this little Gentoo brick hadn't
been updated in 6 months there was a gcc upgrade so I took the
opportunity to do an emerge -e world and start rebuilding the complete
machine. I figure it should be close to done when I get up tomrrow
morning or hopefully by noon. Maybe that will help.

More interesting came from some Googling while this got started. Seems
this is a very common problem and at least some people fixed it by
downgrading mesa from 7.3 to 7.2, so I'l likely try that tomorrow if
this rebuild doesn't fix it. The problem I had there was emerge
started complaining about revisions and that might mean downgrading
all of X or something. (It's a mistake that mythtv-setup is a GUI. It
would be nicer if it was a small script that ran in a console window
for pure server apps.)

I'm not a developer type so I'm reticent to do it but if it's still
broken I'll investigate how to get a backtrace and if successful then
I'll try and get that to the Myth devs. This problem has been going on
one way or another for 4-5 years it seems. I find similar messages
going back to 2004/2005.

Don't worry about not understanding PowerPC. It seems very few do
anymore. I was shocked when I looked at the Gentoo PPC-users list
archives and found that other than me there had only been 2 or 3 other
people ask questions since I built this thing 6 months ago! The
architecture is truly dead, but I'm hopeful that this little box has
enough horse power to control a couple of HDHR's and writing data to 1
or 2 external 1394 drives. It might just be useful, if I can ever get
it to work!

Again, thanks for the help.


More information about the mythtv-users mailing list