[mythtv-users] Long delays with remote occasionally

Allen Edwards allen.p.edwards at gmail.com
Thu May 21 23:22:59 UTC 2009

On Thu, May 21, 2009 at 9:33 AM, Dan Wilga
<mythtv-users2 at dwilga-linux1.amherst.edu> wrote:

> I read through the old posts in this thread, and didn't see an answer to
> these questions about your setup, Allen:
> 1. What CPU does your frontend have?
ADM 5400+

> 2. Why is MFE using USleep for the video timing? Have you tried other
> methods? (Even RTC is an improvement, but vblank is best.)
I have no idea...  As far as I know I am using what mythbuntu came set
up with.  I googled this topic and all I find is that this is set
automatically or that some other methods can be enabled but it is
unclear to me if they will work without a lot of manual intervention.
Where is this documented?  This
http://www.mythtv.org/wiki/Frame_display_timing was not too helpful.

> 3. Does the problem only happen during playback, or in the menus, also?
I have not noticed it with the menus but my wife is unsure, so perhaps
we are not sure.

> 4. Have you completely disabled the screensaver? If you do "ps auxw | grep
> saver" you should get nothing back, except perhaps for the grep itself.
dad at myth_desktop:~$ ps auxw | grep saver
dad      22584  0.0  0.1  15328  3400 ?        Ss   07:56   0:00
dad      24165  0.0  0.0   3008   772 pts/0    S+   16:05   0:00 grep saver

I got something back and I have not disabled it with the exception as
far as I can tell it is disabled by myth when a show is running and I
still have the problem at that time so can't see how that could be it.
 Maybe I am missing something.

> --
> Dan Wilga                                                        "Ook."

Thanks so much for the reply.  My answers to your specific questions
are above.  I took note today when this was being particularly
troublesome and checked the backendlog (nothing) and the frontend log
(not much but posted).  When I looked at the clock and wrote the time
down I wrote 12:29:30 so below is everything around that time.  None
of the errors from last evening are there.


2009-05-21 12:29:01.178 TV: Attempting to change from None to
2009-05-21 12:29:01.280 DPMS Deactivated
2009-05-21 12:29:01.528 AFD: Opened codec 0x8701090, id(MPEG2VIDEO) type(Video)
2009-05-21 12:29:01.529 AFD: codec AC3 has 2 channels
2009-05-21 12:29:01.530 AFD: Opened codec 0x8701410, id(AC3) type(Audio)
2009-05-21 12:29:01.530 AFD: codec AC3 has 1 channels
2009-05-21 12:29:01.531 AFD: Opened codec 0x8701790, id(AC3) type(Audio)
2009-05-21 12:29:01.531 AFD: codec AC3 has 1 channels
2009-05-21 12:29:01.532 AFD: Opened codec 0x8701b10, id(AC3) type(Audio)
2009-05-21 12:29:01.540 Opening audio device 'default'. ch 2(2) sr 48000
2009-05-21 12:29:01.540 Opening ALSA audio device 'default'.
2009-05-21 12:29:01.592 Opening audio device 'default'. ch 2(2) sr 48000
2009-05-21 12:29:01.593 Opening ALSA audio device 'default'.
2009-05-21 12:29:03.341 VideoOutputXv: XVideo Adaptor Name: 'NV17 Video Texture'
2009-05-21 12:29:03.490 OSD Theme Dimensions W: 640 H: 480
2009-05-21 12:29:03.967 TV: Changing from None to WatchingPreRecorded
2009-05-21 12:29:03.971 Using realtime priority.
2009-05-21 12:29:04.068 Video timing method: USleep with busy wait

More information about the mythtv-users mailing list