[mythtv-users] Calling mythfilldatabase with taskset?

Michael T. Dean mtdean at thirdcontact.com
Mon May 11 18:13:42 UTC 2009

On 05/11/2009 01:47 PM, Jay Foster wrote:
>> If you are running on Ubuntu/Mythbuntu, then this is a
>> known issue, but is also harmless. It is based on the
>> version of Qt packaged with the OS.
> I'm running Mythbuntu 8.10 (0.21-fixes) on an Intel Core2Duo and mythfilldatabase regularly segfaults.  I ran the x86 memory test for a day and found no problems, so I believe it is a problem with Myth.  I ran mythfilldatabase manually from a shell and it ran successfully, but segfaulted at the end after it print out something about deleting temporary files.  I'm learning to ignore it.  I wasn't aware that this was a known issue.

No, Matt is right.  It's Qt 3.3.8 that's broken (and it seems some 
distros don't patch it).  

There's actually a very simple patch for Qt to fix it.  
http://www.gossamer-threads.com/lists/mythtv/dev/259316#259316 and 

However, in the case of mythfilldatabase, it's harmless.  If you're 
using a script that calls mythtranscode, however, it will detect the 
segfault as a failure and may not continue (not knowing that it was a 
harmless segfault).  Therefore, this may affect people using nuvexport 
(assuming nuvexport can use mythtranscode and is requested to do so) or 


More information about the mythtv-users mailing list