[mythtv-users] Mythtv-setup Fails

John P. New spm1 at hazelden.ca
Fri May 8 20:42:26 UTC 2009

On May 8, 2009 04:30:53 pm Michael T. Dean wrote:
> On 05/08/2009 04:00 PM, John P. New wrote:
> > I am trying to upgrade my MythTV install (built-from-source version .20
> > on Mandriva 2006) to the latest rpm install on Mandriva 2009.1.
> >
> > I am trying to migrate my mysql database to the new version, and I have
> > used mysqldump as well as the mythconverg_backup.pl and ~_restore.pl
> > scripts. Regardless of whether I am using the restored database or a
> > completely empty one, or using the mc.sql initial database (the only
> > differences in the terminal output are the number of database tables that
> > don't exist), the program finishes with the same error.
> >
> > When I run mythtv-setup, I get:


> > '/mnt/store' Illegal instruction
> > ------------------
> >
> > Any ideas?
> Pretty sure those are mainly non-errors that occur when there is no
> database schema (because of things that happen before the schema is
> created).
> The "Illegal instruction" is the only real error, and that's caused by
> compiling for one architecture and running on a slightly different
> architecture (i.e. compiling for i686 and running on an i586 or something).
> When compiling yourself, do /not/ specify any arch, tune, or cpu options
> to configure.  Simply use: ./configure --enable-proc-opt (and any other
> non-architecture-related options you need, like --enable-dvb, etc.).
> Mike

Well, my old installation (which worked), I compiled myself. My new 
installation is from the rpm packages supplied by Mandriva, so I had no hand 
in compiling those. It may be easier to compile from source once again if this 
is a compile issue.



More information about the mythtv-users mailing list